summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-06 17:56:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-06 17:56:50 +0100
commitf9f5fd57bd4658b42f4e06dae1a509dad49b2ada (patch)
treef4d8a9e91afbe69cc8a9e801b7bfc63a340cfec9 /dev-python/quantities
parentdev-python/sure: Bump to 2.0.1 (diff)
downloadgentoo-f9f5fd57bd4658b42f4e06dae1a509dad49b2ada.tar.gz
gentoo-f9f5fd57bd4658b42f4e06dae1a509dad49b2ada.tar.bz2
gentoo-f9f5fd57bd4658b42f4e06dae1a509dad49b2ada.zip
dev-python/quantities: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/Manifest1
-rw-r--r--dev-python/quantities/quantities-0.14.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/quantities/Manifest b/dev-python/quantities/Manifest
index b251a9fd4e51..260d65d86ee4 100644
--- a/dev-python/quantities/Manifest
+++ b/dev-python/quantities/Manifest
@@ -1 +1,2 @@
DIST python-quantities-0.13.0.gh.tar.gz 107178 BLAKE2B f5fe69ed1d82bc90620a1cabf4c68f676330a2b09e8590bedf48ee8c46e3176d57e0dc6374d1112377056cd1138553d92f0bcaf0a68e2600e3631226e2262afc SHA512 d108b0f5bd834aeb7443693175d54b2b01fa9110cc57f0356681374ce95b5f57e39253d9c8166365aabc379f2f26bba3a827689ceb6c45595345e140b4cd7ad3
+DIST python-quantities-0.14.0.gh.tar.gz 84115 BLAKE2B 549ac64583ebac9a68069e678ee82ac3d9d4462dee4ebffe631c0c20d0819996b0172ceb2cb276aae52ad4dc963e3bfad8f6082d98b90bf6f94c27f807d91565 SHA512 78696938c10e613e1fd6f98f9158d51ec4e86928f9833b73321cde776d77735c119af854aaaff5542093175cd105a33266fba16b31b9e04b51c7f14f648b1e19
diff --git a/dev-python/quantities/quantities-0.14.0.ebuild b/dev-python/quantities/quantities-0.14.0.ebuild
new file mode 100644
index 000000000000..5df00e8a43cb
--- /dev/null
+++ b/dev-python/quantities/quantities-0.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="python-quantities-${PV}"
+DESCRIPTION="Support for physical quantities with units, based on numpy"
+HOMEPAGE="
+ https://github.com/python-quantities/python-quantities/
+ https://pypi.org/project/quantities/
+"
+SRC_URI="
+ https://github.com/python-quantities/python-quantities/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19[$PYTHON_USEDEP]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}