summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-18 22:22:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-18 22:26:21 +0200
commite4ca7a61b3a4b4fa371b290ed27b10be552f2c7d (patch)
treea240e524abd8774b07364b8ec5db25e088345bd0 /dev-python/rdflib
parentdev-perl/Class-MethodMaker: -r bump for EAPI7 (diff)
downloadgentoo-e4ca7a61b3a4b4fa371b290ed27b10be552f2c7d.tar.gz
gentoo-e4ca7a61b3a4b4fa371b290ed27b10be552f2c7d.tar.bz2
gentoo-e4ca7a61b3a4b4fa371b290ed27b10be552f2c7d.zip
dev-python/rdflib: Bump to 5.0.0
Closes: https://bugs.gentoo.org/728616 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-5.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index 75e53685eb11..a905e6351648 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1 +1,2 @@
DIST rdflib-4.2.2.tar.gz 905094 BLAKE2B fe17b5752f67c745bfdf4a160c2f5d49da19f0d85b6eddc4a65fa0ddb660de8bcc19c3ccecf893fb67f725b973cb94481374d9ee0c82072416a93e44952dba9b SHA512 efc24d8ce1080e59950cecc9c779ae0d63673c8690f74db1772f6c2dbf24d6f4de5214d5870a074bffe549b42d8d5f5d131df29bbfd174b763ae1f843aec7d5c
+DIST rdflib-5.0.0.tar.gz 818586 BLAKE2B d0046590b00211ccb4f0f586dc829c061a5f426b1cefed44a63d21d46396354b9012dbe0a63c8f9de138b25ca7d73ba624c49da6fb305ececd983c62c917fd8a SHA512 ba98ab6a7bb9d993d11c559a739761f297282eb9307f3e333db8dd1c6b365b408a59b701d823bef9be774a59b3f44f64c9444e3bb0115c0c549cb00945385dab
diff --git a/dev-python/rdflib/rdflib-5.0.0.ebuild b/dev-python/rdflib/rdflib-5.0.0.ebuild
new file mode 100644
index 000000000000..ee3a9c338a1e
--- /dev/null
+++ b/dev-python/rdflib/rdflib-5.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples sqlite"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # these tests require internet access
+ sed -i -e '/doctest/d' setup.cfg || die
+ rm test/test_sparql_service.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}