summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-10 07:45:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-10 08:32:18 +0200
commitc667936c9fe0b2e6478941661bf7596c150b4c6c (patch)
tree8cfaceee01bbe02b4bfd22f20f920554c7940670 /dev-python/recurring-ical-events
parentdev-python/google-api-python-client: Bump to 2.137.0 (diff)
downloadgentoo-c667936c9fe0b2e6478941661bf7596c150b4c6c.tar.gz
gentoo-c667936c9fe0b2e6478941661bf7596c150b4c6c.tar.bz2
gentoo-c667936c9fe0b2e6478941661bf7596c150b4c6c.zip
dev-python/recurring-ical-events: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.2.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index 729d6fb052a4..422fa97146f4 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1,2 +1,3 @@
DIST python-recurring-ical-events-2.2.1.gh.tar.gz 332458 BLAKE2B 337823e2a98c43015ffd7e848ab4fe43429f787ceb8ff262dca9d73668a785d6245f9e64779c900f1a84a2d7713832621d42044309f38c44bba79fc2853d066f SHA512 1bd6337b5b8670b2c587d54eae26291c381adba76c38e21a937db8a16480d9b4c6eaddda6660fd0c345f67e38ed4f7cfe9e528ecce3686bce9659f4ef30d278c
DIST python-recurring-ical-events-2.2.2.gh.tar.gz 335683 BLAKE2B 1cad8f90f5dcf9e84ac7688e15b8535aaef0c00a0e65a036ef7f38e1b030cc4c017247149d8ef9d099a28a919d015603ebb71c18a44b8bbf26f3f4c3eefbf942 SHA512 0429a344c70c1a844ed2705112776971413e4ed61a54ccb665f0246b208416ad2ce855ff31766bd628439d08432bf4fea8cbf43f878c35835ba6b137bffa3b85
+DIST python-recurring-ical-events-2.2.3.gh.tar.gz 337134 BLAKE2B 6a119c427e176c92f822186aa910eb133f04157069f7a4e632c0b784ab5e71ae37584ceaddf1d0a6d533854d790322130964222eaa00948c6af2bae89491ef00 SHA512 569a21056947d19d85cbf93e02b3fb9236163535d478188a6cdb5b5d7a5e3b460ecf41ac3a2b858e446273aba5d8c5a9b69eebbb3f32ce453e2ee90a31ed1acf
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.2.3.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.2.3.ebuild
new file mode 100644
index 000000000000..6c85248725e5
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-7[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)