summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 19:28:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 19:51:11 +0200
commit658d1a8de47caf63d6ea3d2ce731b305a4bb48dd (patch)
tree191ff7864ba69889e18334cc1f3bdc0e785ba214 /dev-python/requests-cache
parentdev-python/jupyterlab-server: Enable py3.12 (diff)
downloadgentoo-658d1a8de47caf63d6ea3d2ce731b305a4bb48dd.tar.gz
gentoo-658d1a8de47caf63d6ea3d2ce731b305a4bb48dd.tar.bz2
gentoo-658d1a8de47caf63d6ea3d2ce731b305a4bb48dd.zip
dev-python/requests-cache: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/requests-cache-1.1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/requests-cache/requests-cache-1.1.0.ebuild b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
index 0b4386374d3e..8495284f8b9b 100644
--- a/dev-python/requests-cache/requests-cache-1.1.0.ebuild
+++ b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 optfeature
@@ -61,6 +61,16 @@ python_test() {
tests/integration/test_upgrade.py::test_version_upgrade
)
+ case ${EPYTHON} in
+ python3.12)
+ # https://github.com/requests-cache/requests-cache/issues/845
+ EPYTEST_DESELECT+=(
+ tests/integration/test_memory.py::TestMemoryCache::test_response_no_duplicate_read
+ tests/integration/test_sqlite.py::TestSQLiteCache::test_concurrency
+ )
+ ;;
+ esac
+
local -x USE_PYTEST_HTTPBIN=true
epytest
}