summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 18:51:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 19:16:44 +0100
commit10bf36bf424314588822983af71d01154765725d (patch)
treef99ab366d860f1294a73292b0f1797035d0fa815 /dev-python/rich
parentdev-python/bottle: Bump to 0.12.25 (diff)
downloadgentoo-10bf36bf424314588822983af71d01154765725d.tar.gz
gentoo-10bf36bf424314588822983af71d01154765725d.tar.bz2
gentoo-10bf36bf424314588822983af71d01154765725d.zip
dev-python/rich: Bump to 13.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.3.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 22a3158f855b..774efebaca17 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-13.3.1.gh.tar.gz 15055408 BLAKE2B 79713ee232bc1c990c1432f7966cffd69b8ffef9ad8a562339d62b03fbab4620040c5ae1d735d3084d71f32581955f0ea5fad113ff992dcddb2dd0e20465484e SHA512 a3b5bef2183bbb888f0ef5a90b35fdb1ed7ef6103dfea01a5efa441ce8d1769b53d7888684e3b5cd76bcacf3768835d918d9fbb7801eab57c04d1412f129f6bb
+DIST rich-13.3.2.gh.tar.gz 15060707 BLAKE2B fbee6e01b60a18cb32a7f86fa41d621d2cb895e5602f23ed85e7338788f4fbab401fe0a8c2b2bb3a1975c40ebeaaf4d013e50a6d6e5cad6324a14acea21d48dc SHA512 9f33658d8dfa5c22fd92ca83690628ded12d428777d6cd7752afc35c36481d46df1766841eaf003917ec6da932d6f29981c779846d4c14a95e2738e74ec20b2c
diff --git a/dev-python/rich/rich-13.3.2.ebuild b/dev-python/rich/rich-13.3.2.ebuild
new file mode 100644
index 000000000000..8e2a3cb446e8
--- /dev/null
+++ b/dev-python/rich/rich-13.3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}