summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-16 09:14:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-16 09:18:47 +0100
commit4b0500955839a55dd63245e47042b152f50d72a3 (patch)
treee3be78f63e7e3ce23b8618f590fea324228fd78a /dev-python/rq
parentdev-python/colorlog: Remove old (diff)
downloadgentoo-4b0500955839a55dd63245e47042b152f50d72a3.tar.gz
gentoo-4b0500955839a55dd63245e47042b152f50d72a3.tar.bz2
gentoo-4b0500955839a55dd63245e47042b152f50d72a3.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.16.2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 0f644cef16f3..a5fc9d657db5 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
-DIST rq-1.16.2.tar.gz 629881 BLAKE2B 69ac4ba43ea79ddf998bc9f7cf0fc5fa42acb0315dff663b1c924498ccfabdd37ac6d9613e128b838b9e1f45988632a337fb2fa50f5adcd1b69aa520b5ad33e2 SHA512 1c3162b1acffc9d11292fcbff7177267272a02e752b5839a4004b875bb5bb25af7e61f31041df438ef4e0e47152296c3a2711856c6a36d787848dcb766387d1a
DIST rq-2.0.0.tar.gz 639193 BLAKE2B ec44a45618f4ba0cafd30d13d15db8efc26c35f41100019e94d28ac21ca0c6157df34c55fd9bc2c2afdd4752e815a45150c95840339744c005c297153795e598 SHA512 46878626ad939fdc3f31bfd04fab9d11f266a390fe75ea22fde62e1622607e715673a8f3d2e3aba78e489b861d16068836aea4eca5a88cd295d6b6ca61707a41
diff --git a/dev-python/rq/rq-1.16.2.ebuild b/dev-python/rq/rq-1.16.2.ebuild
deleted file mode 100644
index b4c12356976c..000000000000
--- a/dev-python/rq/rq-1.16.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{11..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="
- https://python-rq.org/
- https://github.com/rq/rq/
- https://pypi.org/project/rq/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-4.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires <sentry-sdk-2
- tests/test_sentry.py::TestSentry::test_failure_capture
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}