summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 09:02:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 09:02:00 +0100
commit04ad93378bd54c7681235266c049845ddd39d61e (patch)
tree4bbf4f73a74d989daa55150c327dc6c207758a8a /dev-python/s3transfer
parentdev-python/ruamel-std-pathlib: Update HOMEPAGE (diff)
downloadgentoo-04ad93378bd54c7681235266c049845ddd39d61e.tar.gz
gentoo-04ad93378bd54c7681235266c049845ddd39d61e.tar.bz2
gentoo-04ad93378bd54c7681235266c049845ddd39d61e.zip
dev-python/s3transfer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer')
-rw-r--r--dev-python/s3transfer/Manifest2
-rw-r--r--dev-python/s3transfer/s3transfer-0.5.0-r2.ebuild39
-rw-r--r--dev-python/s3transfer/s3transfer-0.5.1.ebuild41
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/s3transfer/Manifest b/dev-python/s3transfer/Manifest
index e6e3167e8a66..fd9b9479bcc5 100644
--- a/dev-python/s3transfer/Manifest
+++ b/dev-python/s3transfer/Manifest
@@ -1,3 +1 @@
-DIST s3transfer-0.5.0.tar.gz 133535 BLAKE2B 2ce9235fbffc4c42682345873becac6f0d574ac44de523e10178bf7d115b261acbd1753b1a41ca301b72fa96a6a93314572fe12ea4d286a325a0a36e3cf56b36 SHA512 e34d115d149f8f9715fa0147521eec63a5fd672ee513d690248fbca73003cf4c9e43775bd5b3616f7ad3a6734993a1c8b2ba789394d338a8ac4c841a0e51999c
-DIST s3transfer-0.5.1.tar.gz 134278 BLAKE2B e67a726743af4f75e3e22519addeaa4437020ec26e0deec67d003d96307865cb624d7da272618114b168c32f26f595a27ed823b2905f47b1c2e5e187a68457cb SHA512 1bdcb9adfa795b524e36369e9128b1bd39d0b14f51862aba779a1eebe0569283da58138da52e031073d8c1199441083771c7f6e0657e0e1da9cd0d767450d52f
DIST s3transfer-0.5.2.tar.gz 134873 BLAKE2B 55adab89ca04a9ed1f0195237cab55f97769a8f865e645437df6d95effcf1a27a734f1577daa981261123b681044b540ebbb876e1a8a3b4cf1cf4e5018f2c213 SHA512 6b035ff5b33ba5c048f6921f72684802a9b12516c70c75bd153e481e62a768015f45f569aa88071f887839fd2e004b5f9202813926ca33d58c30793218d14083
diff --git a/dev-python/s3transfer/s3transfer-0.5.0-r2.ebuild b/dev-python/s3transfer/s3transfer-0.5.0-r2.ebuild
deleted file mode 100644
index 6b856b48f70e..000000000000
--- a/dev-python/s3transfer/s3transfer-0.5.0-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="An Amazon S3 Transfer Manager"
-HOMEPAGE="https://github.com/boto/s3transfer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/botocore[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest tests/{unit,functional}
-}
diff --git a/dev-python/s3transfer/s3transfer-0.5.1.ebuild b/dev-python/s3transfer/s3transfer-0.5.1.ebuild
deleted file mode 100644
index 458fde84b952..000000000000
--- a/dev-python/s3transfer/s3transfer-0.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="An Amazon S3 Transfer Manager"
-HOMEPAGE="https://github.com/boto/s3transfer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/botocore[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest tests/{unit,functional}
-}