summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 06:41:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:13 +0200
commit33451e157cf26a09589fa26b5e71845108b8f261 (patch)
tree59d86c217a6380e36004bc4ff7e97a7cdc9249f1 /dev-python/scikit-build-core
parentdev-python/pybind11: Bump to 2.13.3 (diff)
downloadgentoo-33451e157cf26a09589fa26b5e71845108b8f261.tar.gz
gentoo-33451e157cf26a09589fa26b5e71845108b8f261.tar.bz2
gentoo-33451e157cf26a09589fa26b5e71845108b8f261.zip
dev-python/scikit-build-core: Bump to 0.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.10.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index bc9625c2c38d..6ea3b98d44fb 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,6 @@
DIST scikit_build_core-0.10.1.tar.gz 251300 BLAKE2B 2727e70c4bfe4e4cf558aaedd3a00eb07268c3e160c6fdfcceb8212842ee1e7e4a6a606c7d1670d25ee1fd45cadf2e40dee847fd5eb627bcf144f239f1ab0f0a SHA512 eebe14d79d339f4c39ab60b05fc6b92f1cd181b6e7ccef74e6976fb990dc51a2db6e6f72c830f6285ca700a48dd3e2ccfc87dafaad9ce26aa32d02fa1795a2b9
DIST scikit_build_core-0.10.2.tar.gz 251394 BLAKE2B 2eb6101ef7558a16ea574a648b1643bd9c701791d9956a865b4c0c0665890c4ee4c945b20638afa339fc1f5fdee1df9671f78a8d459fc09961d6c9e75d263c52 SHA512 8a51401b276073c70a85fd9c44df81eba171edf99af7a3d88b606225abcc83dcd6c2d29170f54bfd521e1141c37fa624292d3e43dccad6a3f6a60b94bf6fda69
+DIST scikit_build_core-0.10.3.tar.gz 251493 BLAKE2B a6616e2e5b997bdf9711cb5afe82a831b8cf960a31c6ca61a2b5c9e39141fe9dbc5698ba1a4002864e40af7ad07d9e627b0cdeaee2866e1a96e00d6732ff9fe4 SHA512 0bbf57555dd0487085940e6c3ac5aa531fada8505b7014353e55d1397ecd1706f87e6c7689c051ada8d2cf20074e0b55e3eb72995faa139719b8fed440dca8c7
DIST scikit_build_core-0.9.10.tar.gz 230104 BLAKE2B e3c4605b4b33260d8deac2cedb7bbb20a08729a36214b13c6071fe9b12f9bddc882c18da0e1ee14d7f1b4845ca0dd02b1c2d5c30c43b96a420c35a8b5cbd2d5e SHA512 0e1cb649f9965f4b13093432a2e36ea9be532ba3b7447c36f898284571dcbcf266b7012a445b464ac9129ec2b91e4155016be1fbab52fc2a979e440b0ea73cac
DIST scikit_build_core-0.9.8.tar.gz 229845 BLAKE2B 419d8891dd3f95bee7f8f7dcc1addb94d2698f8ff392eef19a67e851f57b58d09b9878705d0e8d728d3c6f2b316d538c76471164781fcd1fb5d02dfbfd9d7a85 SHA512 f1206715eef1bdeccddc5987cae4f455522c4ef4dbca305ad7d3772c61f5615c5742b109c5527a5ad5e25a2348abff69ea5ae7153ac18c43cca63783872aa3d5
DIST scikit_build_core-0.9.9.tar.gz 229971 BLAKE2B 2e41f59e053a44db07c84df4a03aab7c574b658d51f4b4517228ef0e12618f8de879e3ef704b7be398b5378e1f19b0a8c8dafcd20e3bd15dece9d387306427ac SHA512 c4b826353be3b34dc7f37f571088b7674f6ad8c984fd9985feb4e1b611c503dbf1a5c0e4e8ad1123c9f2e9538572da319f9104145abd598817ca3e29824cc61d
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.10.3.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.10.3.ebuild
new file mode 100644
index 000000000000..49c374cbe912
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.10.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest-subprocess -m "not isolated and not network"
+}