summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-23 05:37:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-23 06:57:14 +0200
commit8047cee907f2670fcd44dfb1ddc535c436fb0f37 (patch)
tree7b90667439895672ebb6f6b120e402f6234e0526 /dev-python/scikit-build-core
parentdev-python/scikit-build-core: Remove old (diff)
downloadgentoo-8047cee907f2670fcd44dfb1ddc535c436fb0f37.tar.gz
gentoo-8047cee907f2670fcd44dfb1ddc535c436fb0f37.tar.bz2
gentoo-8047cee907f2670fcd44dfb1ddc535c436fb0f37.zip
dev-python/scikit-build-core: Bump to 0.10.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index dca1f6ba8d96..68c4141aef2c 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,3 +1,4 @@
DIST scikit_build_core-0.10.4.tar.gz 252954 BLAKE2B 5d6bf7c7a462a80ee78b1c93a27b7f63443f1acf9bac8918d48882d644de4f11d3532e8afd542a06b24605120d18ab8e094ce9f3997ffd3f8047dcedb97712f9 SHA512 6858a7716f081fc5d40da7b974568855571f7cbc5e8eafdab2547bb6d2abc5445e682d7d7b1f6157e38ecbaad676b90fe1a2b152dcb89331f646180ecb3c6c26
+DIST scikit_build_core-0.10.5.tar.gz 253285 BLAKE2B 6bbd5a92987fcbf9880df902784c9ee1a53d3f58b935b0c43ceb9bb8be0c32878845dd4c35fd03569fdc74d053866ff5e93b8eb96b058623fb357351a16919ec SHA512 283a50b4ff99e9c99fd92f0198231d0c8b68dcfc47ca5a782d7d604d9a313225f9f4e3dbc9490d9cd04f4d66cb79a4f793fb416763717474e83a3fea356b9bac
DIST scikit_build_core-0.9.10.tar.gz 230104 BLAKE2B e3c4605b4b33260d8deac2cedb7bbb20a08729a36214b13c6071fe9b12f9bddc882c18da0e1ee14d7f1b4845ca0dd02b1c2d5c30c43b96a420c35a8b5cbd2d5e SHA512 0e1cb649f9965f4b13093432a2e36ea9be532ba3b7447c36f898284571dcbcf266b7012a445b464ac9129ec2b91e4155016be1fbab52fc2a979e440b0ea73cac
DIST scikit_build_core-0.9.8.tar.gz 229845 BLAKE2B 419d8891dd3f95bee7f8f7dcc1addb94d2698f8ff392eef19a67e851f57b58d09b9878705d0e8d728d3c6f2b316d538c76471164781fcd1fb5d02dfbfd9d7a85 SHA512 f1206715eef1bdeccddc5987cae4f455522c4ef4dbca305ad7d3772c61f5615c5742b109c5527a5ad5e25a2348abff69ea5ae7153ac18c43cca63783872aa3d5
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild
new file mode 100644
index 000000000000..49c374cbe912
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.10.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest-subprocess -m "not isolated and not network"
+}