summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 05:27:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:07:20 +0200
commit9ecce7c9afe64b780a2ee04d0da0df4dcc3a0649 (patch)
treef4c2286361cce7f25905bfe3cf981d953c8b2525 /dev-python/scikit-build
parentdev-python/cachecontrol: Bump to 0.13.0 (diff)
downloadgentoo-9ecce7c9afe64b780a2ee04d0da0df4dcc3a0649.tar.gz
gentoo-9ecce7c9afe64b780a2ee04d0da0df4dcc3a0649.tar.bz2
gentoo-9ecce7c9afe64b780a2ee04d0da0df4dcc3a0649.zip
dev-python/scikit-build: Bump to 0.17.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest1
-rw-r--r--dev-python/scikit-build/scikit-build-0.17.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 8c0ef17fe54d..7f517f98de26 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,3 +1,4 @@
DIST scikit-build-0.16.4.tar.gz 271037 BLAKE2B 6cca8a3c4f4b37228b77ac098650a5eca4ad0f525ca7dcba178f4cffabb7e60e9a7bbba244e64c1a598ab5916f2f47788198eb2a19803d8d0cf7b9792f4e06e2 SHA512 90315ceac4c372e4d7248b4b56b6092362c2c43fbdc180d1a234e057209c508a05d2c6e0a3d0c2587c3adb8957e4c66d5c171a2a2bc3dbf9874a0de58d97d976
DIST scikit-build-0.16.7.tar.gz 274287 BLAKE2B 8a5064c021d904312ccf89a396ab794b89b73ad1b6238767ca74eeb394f0f1514eedd3c746353ee3e9e7b825988b3c52c563e1f19d0acfbe69213c5a306f1dcc SHA512 5bba94214c249f891b2972301b0e37b5f10938151e37a04b845dfc9e11ae85edc7e3880984f9fbbd1c037257fc8baa3ba7b006b1f1b7abb941d1a54e049f3cbc
DIST scikit_build-0.17.5.tar.gz 269848 BLAKE2B df1ec6ff3791efeea0ea7b672b7c5d2ad946c9c8d1e8b7035f4036315701ad1b7d61b0917e75ca8c9aff10fe8f25e53b8d1221fa6c3b554225ff8d8f5dec5fd4 SHA512 f0c9a861f9931db36df137d96a9a53d2bfa4a696efc2c1307ff50a00f7df828042d933ef1f670d14d0a339ccf5b94ce99fca7ffbab9169b6e70c47440f4eef06
+DIST scikit_build-0.17.6.tar.gz 272208 BLAKE2B 9e3f908041eca89182f798c54a1a248934dc026816f7cd041a8debc97be27096942dda42a0ae63e87b9337304a478d6f520edcd5ea7a45aae6a195d1f769eed2 SHA512 92b97146f40d8222bd8415ef8439497d5075b72e5bafc40aba0a3e2911d269a118f2f7d41f468f7add8949f550b1fd7d5a9113d249e42dfac431108182ca9198
diff --git a/dev-python/scikit-build/scikit-build-0.17.6.ebuild b/dev-python/scikit-build/scikit-build-0.17.6.ebuild
new file mode 100644
index 000000000000..24b2bbb94ac3
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.17.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -m "not isolated and not nosetuptoolsscm"
+ rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg,*.egg-link} || die
+}