summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-20 14:44:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 16:19:55 +0300
commit83a4e16567756b4e741773a8ef4e89ca304883e7 (patch)
tree30d20ebe62be3125423a7b03771faf8dddaf3031 /dev-python/selenium
parentdev-embedded/avrdude: drop 6.3, EAPI-6-- (diff)
downloadgentoo-83a4e16567756b4e741773a8ef4e89ca304883e7.tar.gz
gentoo-83a4e16567756b4e741773a8ef4e89ca304883e7.tar.bz2
gentoo-83a4e16567756b4e741773a8ef4e89ca304883e7.zip
dev-python/selenium: add 4.4.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest1
-rw-r--r--dev-python/selenium/selenium-4.4.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 8b41b5af4e3d..312f20e8a60c 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,3 @@
DIST selenium-3.141.0.gh.tar.gz 155705874 BLAKE2B f75eec80e6caa86744092020abaeef56defcfac8278dd3fd605c29d6860c1c046956c7599164ba1b4682f20dfa997f5a942d83f7ad707b052ad3ca98c0800527 SHA512 add14d426c5b929901cd71104460c7ceaacf46374b46898254dc2e2602f4a9a370199da603e3f35375c0f297d6fc2fda00c9ce2ede9d5b893b072e0487883df2
DIST selenium-3.141.0.tar.gz 854669 BLAKE2B 621f4ab03bf85718b50099fdf10cdfadaf326bc7d9c9f1676a2a20e3ad23bede7884d8017b98bc6ebc314c6a4221c7668628d2d1888f36350c95eed1d82acee7 SHA512 3d2afbe9e96f88e9c055a89786b5090af387d3feba4598577b70fd3e0b20c2c09c4b25af920c654f52ec7e34f23181e6d278ac05f1a1f960d2d371ce7a6b82d8
+DIST selenium-4.4.3-py3-none-any.whl 985964 BLAKE2B b89c8d8c8a59c6fc8cc6aae84456e6e30f651148880f54bac84f4d82a2281d4ca1841e872fed80746c75fc795b8154c925386245f36940c9a54b1ac746d984dc SHA512 14142389a19cd311be229555b06c7dec5a11f852332775def10b6ffd956d07d0394f7af1463fc18116b0e4df055168158a5c2cc6794af760f16b6ae6ebb88aa4
diff --git a/dev-python/selenium/selenium-4.4.3.ebuild b/dev-python/selenium/selenium-4.4.3.ebuild
new file mode 100644
index 000000000000..5a7d0c13ff2d
--- /dev/null
+++ b/dev-python/selenium/selenium-4.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# GitHub releases don't include generated files, and on PyPi we do have them
+# but only in a wheel format.
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="https://www.seleniumhq.org"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${P::1}/${PN}/${P}-py3-none-any.whl
+"
+S=${WORKDIR}
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}