summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-10 22:29:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-10 22:29:03 +0200
commit0e34ed2923cb3fa467df35fe596906c1b77839d4 (patch)
tree2a5a13c41b95cf045816515d8d366348b49be0bc /dev-python/sentry-sdk
parentdev-python/sqlalchemy: Stabilize 1.4.28 arm64, #830952 (diff)
downloadgentoo-0e34ed2923cb3fa467df35fe596906c1b77839d4.tar.gz
gentoo-0e34ed2923cb3fa467df35fe596906c1b77839d4.tar.bz2
gentoo-0e34ed2923cb3fa467df35fe596906c1b77839d4.zip
dev-python/sentry-sdk: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.2.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.2.ebuild
index 37a746c140e3..f7fe237c12d9 100644
--- a/dev-python/sentry-sdk/sentry-sdk-1.5.2.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-1.5.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python client for Sentry"
@@ -24,7 +24,6 @@ BDEPEND="
dev-python/asttokens[${PYTHON_USEDEP}]
dev-python/django[${PYTHON_USEDEP}]
dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
dev-python/fakeredis[${PYTHON_USEDEP}]
dev-python/flask-login[${PYTHON_USEDEP}]
dev-python/gevent[${PYTHON_USEDEP}]
@@ -36,6 +35,9 @@ BDEPEND="
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
)
"