summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 09:56:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 10:04:22 +0200
commita8744fcecf421624944723206ca28586027e7cde (patch)
treee5533b118ac93c63925344207bd9866c1a2ca5ee /dev-python/sh
parentdev-python/rich: Enable py3.11 (diff)
downloadgentoo-a8744fcecf421624944723206ca28586027e7cde.tar.gz
gentoo-a8744fcecf421624944723206ca28586027e7cde.tar.bz2
gentoo-a8744fcecf421624944723206ca28586027e7cde.zip
dev-python/sh: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/sh-1.14.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.14.2-r1.ebuild b/dev-python/sh/sh-1.14.2-r1.ebuild
new file mode 100644
index 000000000000..328e3db4b79c
--- /dev/null
+++ b/dev-python/sh/sh-1.14.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
+ "${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}