summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Sirabella <marco@sirabella.org>2023-02-10 01:25:46 -0800
committerJoonas Niilola <juippis@gentoo.org>2023-03-01 15:46:09 +0200
commita0071ed9b4607c23ef216ca159b842fa5bb047a1 (patch)
tree1a280e1158098e4c7915f09d2ccc69141bc15d32 /dev-python/sphinx-autoapi
parentdev-python/sphinx-autoapi: bump to 2.0.1 (diff)
downloadgentoo-a0071ed9b4607c23ef216ca159b842fa5bb047a1.tar.gz
gentoo-a0071ed9b4607c23ef216ca159b842fa5bb047a1.tar.bz2
gentoo-a0071ed9b4607c23ef216ca159b842fa5bb047a1.zip
dev-python/sphinx-autoapi: Ignore tests conditionally
Closes: https://bugs.gentoo.org/892607 See-also: https://github.com/readthedocs/sphinx-autoapi/issues/368 Signed-off-by: Marco Sirabella <marco@sirabella.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild11
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.0.1.ebuild13
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
index ccd674abfc2c..1e05cb3afb91 100644
--- a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
@@ -39,3 +39,14 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # https://github.com/readthedocs/sphinx-autoapi/issues/368
+ if has_version ">=dev-python/sphinx-6.0"; then
+ EPYTEST_DESELECT+=(
+ tests/python/test_pyintegration.py::TestPositionalOnlyArgumentsModule::test_integration
+ )
+ fi
+
+ distutils-r1_python_test
+}
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.1.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.1.ebuild
index d640adbe32b5..06e4095ca49a 100644
--- a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.1.ebuild
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.1.ebuild
@@ -39,3 +39,16 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # https://github.com/readthedocs/sphinx-autoapi/issues/368
+ if has_version "<dev-python/sphinx-6.0"; then
+ EPYTEST_DESELECT+=(
+ tests/python/test_pyintegration.py::TestPositionalOnlyArgumentsModule::test_integration
+ tests/python/test_pyintegration.py::TestPy3Module::test_annotations
+ tests/python/test_pyintegration.py::TestAnnotationCommentsModule::test_integration
+ )
+ fi
+
+ distutils-r1_python_test
+}