summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-20 19:35:07 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-20 20:07:12 +0100
commit1ca0f6c84d34db49092567aaf49d29bd4da720e4 (patch)
treec9efeb9201281f0265756705044a5b004ec4bd70 /dev-python/spyder-unittest
parentdev-python/spyder-unittest: add version 0.5.0 (diff)
downloadgentoo-1ca0f6c84d34db49092567aaf49d29bd4da720e4.tar.gz
gentoo-1ca0f6c84d34db49092567aaf49d29bd4da720e4.tar.bz2
gentoo-1ca0f6c84d34db49092567aaf49d29bd4da720e4.zip
dev-python/spyder-unittest: cleanup old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest2
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild46
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild41
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
index e9a384328d02..22be279e4c0c 100644
--- a/dev-python/spyder-unittest/Manifest
+++ b/dev-python/spyder-unittest/Manifest
@@ -1,3 +1 @@
-DIST spyder-unittest-0.4.1.tar.gz 79158 BLAKE2B 10b7a8fde9dffdb436c44f22d305ceab84970dabd19aaeb7b5685be21f0e7bfc701a5fbbf9e393a71c9feb36dd6a2be68680e276c8d0841b2133a7171c504e3f SHA512 17e08b09accd938bf533c409f9a8011e9780f9cc4533af0ec754b6a01061490f198213cb77af9050e1e67e2b4b9c25251bbab27dce23d3f6e09f502cfbef95fc
-DIST spyder-unittest-0.4.1_p20220106.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
DIST spyder-unittest-0.5.0.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild
deleted file mode 100644
index 38bdd2eb9179..000000000000
--- a/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Plugin for Spyder to run tests and view the results"
-HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
- <dev-python/spyder-5.1[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-# Tests fail with spyder-5, however the plugin does load and is usable
-RESTRICT="test"
-
-distutils_enable_tests pytest
-
-python_test() {
- spyder_unittest_test() {
- # fails to test in ${BUILDIR}/lib
- # test do work if executed directly in the extracted tarball
- local PYTHONPATH="${WORKDIR}/${P}"
- pytest -vv spyder_unittest/tests spyder_unittest/widgets/tests
- }
-
- virtx spyder_unittest_test
-}
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
deleted file mode 100644
index e60fa49b0a8b..000000000000
--- a/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
-
-DESCRIPTION="Plugin for Spyder to run tests and view the results"
-HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-# AttributeError: 'NoneType' object has no attribute 'split'
-RESTRICT="test"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-
-python_test() {
- virtx epytest
-}