summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-11 11:39:03 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-11 11:41:26 +0200
commit549490380373b6bfeef16c55227824dd2a24b991 (patch)
tree1a0d42ebdd42dd723fefc492bd4d4c5292285974 /dev-python/spyder
parentdev-python/spyder-kernels: allow ipython-8 (diff)
downloadgentoo-549490380373b6bfeef16c55227824dd2a24b991.tar.gz
gentoo-549490380373b6bfeef16c55227824dd2a24b991.tar.bz2
gentoo-549490380373b6bfeef16c55227824dd2a24b991.zip
dev-python/spyder: allow ipython-8
Bug: https://bugs.gentoo.org/843251 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/spyder-5.3.0-r1.ebuild (renamed from dev-python/spyder/spyder-5.3.0.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/spyder/spyder-5.3.0.ebuild b/dev-python/spyder/spyder-5.3.0-r1.ebuild
index b12d9ce717ad..868ae5625d61 100644
--- a/dev-python/spyder/spyder-5.3.0.ebuild
+++ b/dev-python/spyder/spyder-5.3.0-r1.ebuild
@@ -126,6 +126,7 @@ python_prepare_all() {
# Do not depend on pyqtwebengine<5.16, this dependency is carried by QtPy[webengine]
# Do not depend on parso and jedi, this is dependency is carried in python-lsp-server
# Do not depend on python-lsp-server, this dependency is carried in pyls-spyder
+ # Do not depend on ipython, this dependency is carried in spyder-kernels
# The explicit version requirements only make things more complicated, if e.g.
# pyls-spyder gains compatibility with a newer version of python-lsp-server
# in a new release it will take time for this information to propagate into
@@ -139,6 +140,7 @@ python_prepare_all() {
-e '/parso/d' \
-e '/jedi/d' \
-e '/pylint/d' \
+ -e '/ipython/d' \
requirements/conda.txt || die
sed -i \
-e "/'pyqt5[ 0-9<=>.,]*',/d" \
@@ -147,6 +149,7 @@ python_prepare_all() {
-e "/'parso[ 0-9<=>.,]*',/d" \
-e "/'jedi[ 0-9<=>.,]*',/d" \
-e "/'pylint[ 0-9<=>.,]*',/d" \
+ -e "/'ipython[ 0-9<=>.,]*',/d" \
setup.py || die
sed -i \
-e "/^PYLS_REQVER/c\PYLS_REQVER = '>=0.0.1'" \
@@ -154,6 +157,7 @@ python_prepare_all() {
-e "/^PARSO_REQVER/c\PARSO_REQVER = '>=0.0.1'" \
-e "/^JEDI_REQVER/c\JEDI_REQVER = '>=0.0.1'" \
-e "/^PYLINT_REQVER/c\PYLINT_REQVER = '>=0.0.1'" \
+ -e "/^IPYTHON_REQVER/c\IPYTHON_REQVER = '>=0.0.1'" \
spyder/dependencies.py || die
# do not check deps, fails because we removed dependencies above