summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 14:53:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 18:18:50 +0100
commitbe29708d9b8ffe96febb46a677577d1c576c9d43 (patch)
tree78b129f578ea4cbdc9fd039b59657af843a6c390 /dev-python/stomp-py
parentdev-python/sphinx_ansible_theme: Use pypi.eclass (diff)
downloadgentoo-be29708d9b8ffe96febb46a677577d1c576c9d43.tar.gz
gentoo-be29708d9b8ffe96febb46a677577d1c576c9d43.tar.bz2
gentoo-be29708d9b8ffe96febb46a677577d1c576c9d43.zip
dev-python/stomp-py: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/stomp-py/stomp-py-8.1.0.ebuild b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
index 2aaf49e80681..a779d1c0f9e0 100644
--- a/dev-python/stomp-py/stomp-py-8.1.0.ebuild
+++ b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
@@ -4,16 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-MY_PN="${PN//-/.}"
-MY_P="${MY_PN}-${PV}"
+inherit distutils-r1 pypi
DESCRIPTION="Python client library for the STOMP messaging protocol"
HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,8 +19,6 @@ KEYWORDS="~amd64"
RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
-S="${WORKDIR}"/${MY_P}
-
# stomp.py test suite requires quite a few appropriately configured
# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
# stompserver). Upstream relies on Docker to provide those servers, however