summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 18:01:54 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 19:09:55 -0800
commit1ede76077ab5ee4019731753328024ef85ae46cf (patch)
tree7e3cc929ce944a0f2a99aaab4fd899519f3ab288 /dev-python/termcolor
parentdev-cpp/gflags: arm64 stable (bug #700774) (diff)
downloadgentoo-1ede76077ab5ee4019731753328024ef85ae46cf.tar.gz
gentoo-1ede76077ab5ee4019731753328024ef85ae46cf.tar.bz2
gentoo-1ede76077ab5ee4019731753328024ef85ae46cf.zip
dev-python/termcolor-1.1.0-r2: Revbump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/termcolor-1.1.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/termcolor/termcolor-1.1.0-r2.ebuild b/dev-python/termcolor/termcolor-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..1840594ae3f6
--- /dev/null
+++ b/dev-python/termcolor/termcolor-1.1.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSII Color formatting for output in terminal"
+HOMEPAGE="https://pypi.org/project/termcolor/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no tests...
+RESTRICT="test"