summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 19:01:51 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 19:32:54 +0100
commit81dab8f7b185553f473a1c0c31f2aeb061d49c09 (patch)
tree4b77d5857fc513f938519ab2912d1977e119e6b2 /dev-python/testfixtures
parentdev-python/griffe: Bump to 0.41.1 (diff)
downloadgentoo-81dab8f7b185553f473a1c0c31f2aeb061d49c09.tar.gz
gentoo-81dab8f7b185553f473a1c0c31f2aeb061d49c09.tar.bz2
gentoo-81dab8f7b185553f473a1c0c31f2aeb061d49c09.zip
dev-python/testfixtures: Bump to 8.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-8.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 06c07a7b8667..e32bda057723 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,2 +1,3 @@
DIST testfixtures-7.2.2.tar.gz 133809 BLAKE2B 6a3701bb9c5ca476aadc144f1013268f87e10dd47a6f757e8a0aaa3feb33e1a06663a38f0789b7c54cf439b07562dfb638bd9b89efdc36831d04977f6035ecc8 SHA512 4f7a5ed659b650080deac0b1caff6d2dff0b71d23eaeb26b48b7daa4df85dc0a1f6cfef98275c9a90289eb893c0a06311c849b84f2cc35447fb766f4d0d41c89
DIST testfixtures-8.0.0.tar.gz 133847 BLAKE2B 0197f1946b6124298251a2d0bedf706f36982b1f10c8f959fe1ac52aa8290a9123355a110aa2bdf932229bd152bd041f086eba76b29aa97f9df2f8a1b3a3f7c3 SHA512 57d7876cccda12f3abb47c50e15c5a9e2cbae2039a573733cb10d1708245f20adbf959fec34fd06edf1ba9279a10e336b34acd8bda0cf1f8a64f9940bd5c8c2b
+DIST testfixtures-8.1.0.tar.gz 134639 BLAKE2B 9f930d15b039a808717e06d86711553c4b165b39927c36901a78a028d227a9aaa39b05091192bcaf15a579f08262e8f9561670e959d6cfa58541f2213f8c15ef SHA512 17aa2be892e8095d2386b72e72daa73689fb44283a168a0cb3fad8c847cd9527e4e273cf0ac527cdd2579f2e0689074de77b26c1124e3ae7aa7efce0f5909fec
diff --git a/dev-python/testfixtures/testfixtures-8.1.0.ebuild b/dev-python/testfixtures/testfixtures-8.1.0.ebuild
new file mode 100644
index 000000000000..5bd6337f763e
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-8.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="
+ https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ >=dev-python/sybil-6[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}