summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:51:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 06:51:11 +0200
commit9144cbe23b12226412566f20f082790526242853 (patch)
treeba27933f8cedf52197e12396fc6950b7ddbc815a /dev-python/testfixtures
parentdev-python/typing-extensions: Bump to 4.12.2 (diff)
downloadgentoo-9144cbe23b12226412566f20f082790526242853.tar.gz
gentoo-9144cbe23b12226412566f20f082790526242853.tar.bz2
gentoo-9144cbe23b12226412566f20f082790526242853.zip
dev-python/testfixtures: Bump to 8.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-8.3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 1b1938f66dc8..492bc318ba8a 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-8.2.0.tar.gz 136662 BLAKE2B 37dcc8c718a0db51d42f7f7c5b8876e852d4e9ddbd157ce7f278c0ccbd304ce923e41e5126ee9194680059274fad04567de6e56976b281249e85e540b1a984d8 SHA512 a151767ea44a36c244e4c46fc2ce8665ebc64a52159213e5739f78537e684d6760b03a56b393894afabb70a5d777e3b9fbe0aa8acec33c958fc973eda3ec1e5e
+DIST testfixtures-8.3.0.tar.gz 137420 BLAKE2B bf0fe6705bbbb33a26dcc98be061c1dafbe331ca6c4ac8c028e146f7e156870ee8abe5118b3182600e8d513530c442a4fa1efa696253b9b0c114733bd40fc6ee SHA512 b2c18a35c44b90bce50cc68ca9bf9909ac8f75287c7188eeddfa855aec1db3bd14f3fccb4c5ef0e44b19c683ad4bd6be4876554ce9127698e8e20cbfa4191800
diff --git a/dev-python/testfixtures/testfixtures-8.3.0.ebuild b/dev-python/testfixtures/testfixtures-8.3.0.ebuild
new file mode 100644
index 000000000000..07bcb3d54340
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-8.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="
+ https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ >=dev-python/sybil-6[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ sys-libs/timezone-data
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}