summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 15:54:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 17:59:43 +0100
commit513ea52ec47d187d4934e816a1f2a6a2b1d85d0b (patch)
treedef6d068be02c14017956af95b7d7288d68a88b7 /dev-python/thunarx-python
parentmedia-sound/vmpk: Drop 0.7.2-r1 (diff)
downloadgentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.tar.gz
gentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.tar.bz2
gentoo-513ea52ec47d187d4934e816a1f2a6a2b1d85d0b.zip
dev-python/thunarx-python: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest1
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
index 14446bb83c71..052e6af214dd 100644
--- a/dev-python/thunarx-python/Manifest
+++ b/dev-python/thunarx-python/Manifest
@@ -1 +1,2 @@
DIST thunarx-python-0.5.1.tar.bz2 334426 BLAKE2B 59f8e625b10ceeaefffa4b6dde150c32023365e76854c6e77ae2f222b509856353c8d62de26ba4e7b967cfcce1219205923938389fd1714a420bc9e1ac2b12b2 SHA512 0c1d8f20b74a3eb87b3c2c181c6438bc059dff75afdc26cfea19dffb7efe1f14e6a880689f73afcbbcb5922312741df72018e3b9980c4a45426e7a7d4651177f
+DIST thunarx-python-0.5.2.tar.bz2 348120 BLAKE2B ddb098857a7411c1ce4dedf8b406cf6583e78f2ca4b012a9e0346c5a7132c40fd9cf279dc5d054ec827028cdc67321a65fab5e9d3912287ea9ed1f0cf4e72248 SHA512 49d009c84d69f0a1938ed6cb46fe04326c7323edecd79f6d9978ce2306fb95f20c901174f1cea31d5e436c85537efcb79c8613be857a3e4143f7b55b895616b6
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
new file mode 100644
index 000000000000..3c38ae815633
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/thunar-1.7.0
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}