summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-11 06:53:50 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-11 07:52:08 +0100
commiteb5e984ff86be666b21b698d82b782cade2072f1 (patch)
tree3ce51079f3af65816710a4fb5fdbf58c2402a2f2 /dev-python/tifffile
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-eb5e984ff86be666b21b698d82b782cade2072f1.tar.gz
gentoo-eb5e984ff86be666b21b698d82b782cade2072f1.tar.bz2
gentoo-eb5e984ff86be666b21b698d82b782cade2072f1.zip
dev-python/tifffile: Bump to 2025.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2025.1.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index eb781f64c3ba..4a50732f6b89 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2024.12.12.gh.tar.gz 354766 BLAKE2B f4f6a8be64a16dd2c34b9f1f80ac390a7211515f0b96b54a43e132b0040130689e6e7eccd1668ec7f112bc204efb89cfc9f5cc4d37f6168d8e64fa9c82c8b371 SHA512 ef4895739304d6cb0cb9f6af0156da1915105ab5a10dbb07e52ee7168b7bbd9f6f7e8f5d291aa6cb52df48d25064fb6f9a73495c8b80969048d64c05dcd74ff5
+DIST tifffile-2025.1.10.gh.tar.gz 354970 BLAKE2B c646ea217a66b24f7afb8a4de86d2cecf9707caf94e8c8f82012bcb6cae89b49e37866c963900238c4f941ea31c66683db1cd7f0e9f531af62e1dd228c40d4da SHA512 568f0be93e84321a3dc2bed91a2f32477813d9416e356c9c9e139dbe628dfebb2ea3c395b6e5fd7bf9bdc681db0fa1eb0b0a82b502ea5afb9010d11558851ae1
diff --git a/dev-python/tifffile/tifffile-2025.1.10.ebuild b/dev-python/tifffile/tifffile-2025.1.10.ebuild
new file mode 100644
index 000000000000..acb6ec9229bb
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2025.1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}