summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 07:41:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 08:09:14 +0100
commitea9a121395a1414a27d9619bbf0fce6cf0fca3eb (patch)
tree25dd65b813e449731839a77024dd263b3d451206 /dev-python/tox
parentdev-python/jsonschema: Bump to 4.17.3 (diff)
downloadgentoo-ea9a121395a1414a27d9619bbf0fce6cf0fca3eb.tar.gz
gentoo-ea9a121395a1414a27d9619bbf0fce6cf0fca3eb.tar.bz2
gentoo-ea9a121395a1414a27d9619bbf0fce6cf0fca3eb.zip
dev-python/tox: Bump to 4.0.0_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.0.0_rc1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 7f47f597f3f1..383426d340a6 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1 +1,2 @@
DIST tox-3.27.1.gh.tar.gz 309006 BLAKE2B fa8aaa9cd5b03e54c166bb6b748290420b91498b26d2d124d9f88a64806b9ac0578c1886845b25aa024907f6a782c45609fa6c7657d9e1f538b59c2d9f0f4e14 SHA512 5f568bc6c53f871aae91928681dd6f2419b876a8e6ca925e65abae845b548ee3d00513741882875bbbacb78bf64935228d98213f940d3da8c3f788b73f177b79
+DIST tox-4.0.0rc1.gh.tar.gz 273212 BLAKE2B c9123aa23185655c32ebac36adf24ba8cfc57e8a94c011657acff6a5ce5bede8b14218a21a8cae099fdc2af938343336bea7fed802f8f73bc7769cd17b52d918 SHA512 6619fad1a080a095b827968972dd0d854ca5b48b81ef6548d8c39accc30c0279f9e0cc4208b148920e51fe304328dbdf4f4a8c4554b32398baf243484bba338d
diff --git a/dev-python/tox/tox-4.0.0_rc1.ebuild b/dev-python/tox/tox-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..52c45d18ed20
--- /dev/null
+++ b/dev-python/tox/tox-4.0.0_rc1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cachetools-5.2[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.1.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.16.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ >=dev-python/time-machine-2.8.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+
+ epytest
+}