summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 03:45:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 03:45:34 +0200
commit37e5e9d90e438a25ad7045ea7924501bc52581ce (patch)
tree23882e8383eb6eea2a2cfa1c9e1b93027f31c9d4 /dev-python/trimesh
parentdev-python/astroid: Bump to 3.2.3 (diff)
downloadgentoo-37e5e9d90e438a25ad7045ea7924501bc52581ce.tar.gz
gentoo-37e5e9d90e438a25ad7045ea7924501bc52581ce.tar.bz2
gentoo-37e5e9d90e438a25ad7045ea7924501bc52581ce.zip
dev-python/trimesh: Bump to 4.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.4.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 3cdd7cec9d68..9e3f40be5fc7 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-4.4.0.gh.tar.gz 13599198 BLAKE2B 41fe6d8797bca600ef4526420b9a4bc3fe722adff3a6154625801b2e9a8645ad573f4f62926cd00763899d049660145d6e5614316fcfe3c4f4b76c59d59467ba SHA512 227f3da9e42bd2a872d312d5128d7ae169fcee8ef5566e533812fc6222fe6e5dc40c7802a5a7f1bbb583c700e6c8d1017ee1c6a946284e64679f3a138f31da6e
DIST trimesh-4.4.2.gh.tar.gz 13607230 BLAKE2B fb1b904b873f1ace0956210ce01039a24dadeeb7d7316cae5c55286dead56d95a8fcb4a02b7193d0bf416c60ed1d5a0e3f475c63f45fcd75691f7ac9066ed845 SHA512 1b69fe5792236270c0351dba580edf3238a9f5235faa968078d52a085b818ef20772a360110b89d413bb916c07fb7db58db0c4d6ecbf8e69a436c2bae2d54fc8
+DIST trimesh-4.4.3.gh.tar.gz 13606522 BLAKE2B d59c59e11b67c301c0171dc911cf1e518b57f9b3e9d0d4410130922eb0fc5b190ec5d8088e43d35fb7b09687a2698fe41342ce492fafc7bb050431cf43624c9b SHA512 b93ed203589a5467116c942b6d02db7eb4c130b7f110ea2612a2cf4d86d9f7943b949dd62d2229762a2a14f796041aa6a4294857a8fcc3b96d470a6925b9d568
diff --git a/dev-python/trimesh/trimesh-4.4.3.ebuild b/dev-python/trimesh/trimesh-4.4.3.ebuild
new file mode 100644
index 000000000000..37fd5b19ad93
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.4.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}