summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 06:47:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 06:52:24 +0200
commit4d9a4723daa54a6906da00cd162db23e9e888c28 (patch)
tree5382c2ec403542c44c5e41398f08fc093e3cb05e /dev-python/trove-classifiers
parentdev-python/phonenumbers: Bump to 8.13.37 (diff)
downloadgentoo-4d9a4723daa54a6906da00cd162db23e9e888c28.tar.gz
gentoo-4d9a4723daa54a6906da00cd162db23e9e888c28.tar.bz2
gentoo-4d9a4723daa54a6906da00cd162db23e9e888c28.zip
dev-python/trove-classifiers: Bump to 2024.5.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.5.17.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index db183d2aec56..e5fb21529446 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove-classifiers-2024.4.10.tar.gz 16036 BLAKE2B bfd0ae5e3e1dc2dab67e66dc9cdf90b3ff789d00fff5f13ddf8974736adf3e37c505488d4aea32b0c4b43a6d77617e9a0672def2e66baf813734b1e3bebb8bd3 SHA512 2705ea82869bb3092dd37c817d5263955249b44ad64c0fcedc523ecc78eaeb2a327500adbafe70c5d08b5961bf8095748e34a0daa1a2ba8db3fa27e1a35a645b
+DIST trove_classifiers-2024.5.17.tar.gz 16046 BLAKE2B b4b0c2d1a7dd551be2c0da69fc57d4f489d61a5f2eff9345c557409f12ab51185bcaa72d4f8cf6d9738fc474594bde0de46b0cba9277abd2c19f570e6d84e5fa SHA512 2268b79f38d4f1a6ca109556daf1a90c88d7e6c6446e9bcbdbd3669e723aacbbec14f2e2c89c21c6991dc72a3f16839514f67c0c5b716e04feb19e74a0fed7fc
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.5.17.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.5.17.ebuild
new file mode 100644
index 000000000000..8fea4e4a1421
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.5.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}