summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-02 07:03:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-02 08:58:37 +0200
commit8a307e23aacc8b23807848fa7d50109b206797b0 (patch)
tree999e037fb36ef91638d1d69e94ba43e5261667b4 /dev-python/trove-classifiers
parentdev-python/inflect: Bump to 7.3.1 (diff)
downloadgentoo-8a307e23aacc8b23807848fa7d50109b206797b0.tar.gz
gentoo-8a307e23aacc8b23807848fa7d50109b206797b0.tar.bz2
gentoo-8a307e23aacc8b23807848fa7d50109b206797b0.zip
dev-python/trove-classifiers: Bump to 2024.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 33fe4d4e46a6..e0e985223024 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove_classifiers-2024.5.22.tar.gz 16050 BLAKE2B e9909972067f1ec825a127801483aa5d6c47bc7c7442bfc4490eec2628003fa0d25362ad10255b20174beb93cfd382df43a948c73c9c8834307d660897d8162f SHA512 34fd1e47f41563e6e9471ae029897d96fec8119368a1bfd8b8982b26c56a1e9e0b154dcd155b401cf537cbfba574e3ca659a31865f3d0718dfa3bc1eb1ec1ea1
+DIST trove_classifiers-2024.7.1.tar.gz 16060 BLAKE2B 4b662d9f440423167d4e715beebaa5993d83dfbab575e9c5b1a549b60f85abb9e10cec09c702d403e3655cafd002b9bf67c02808bbfac6746b2c395f8a0ce102 SHA512 c3092bce086f0530ca10326d2e99ea331e73b31fe47272835ff1a1042588dc616ccf8ce5e6eda5d48b5f199bc5c1a3206d4f17be62dbf751029e498c1231bd11
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild
new file mode 100644
index 000000000000..8fea4e4a1421
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}