summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-16 22:41:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-17 08:42:20 +0200
commitc3f157553d74497a8e6c2b2409c49580b2582b5d (patch)
tree17473bef7cdd717dcc7e701b83b543375f87d822 /dev-python/ujson
parentdev-cpp/tbb: add another musl patch (diff)
downloadgentoo-c3f157553d74497a8e6c2b2409c49580b2582b5d.tar.gz
gentoo-c3f157553d74497a8e6c2b2409c49580b2582b5d.tar.bz2
gentoo-c3f157553d74497a8e6c2b2409c49580b2582b5d.zip
dev-python/ujson: add 5.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-5.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 651358114bc3..f23d1ad9124f 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1,2 +1,3 @@
DIST ujson-4.3.0.tar.gz 7129405 BLAKE2B 434a686d319415391910c2d8358b97b27221fe8ec725394c066126e9f0b05f8624db6fd2b372add7d3629733f108e8a0d4b840328499aadf43dda3397e07aef9 SHA512 62a84562a95dbbd0825c9c961f8b769c908201c56a1981bb22809f11e7330f68a1c5fa86c182a6c7823a4d780b1afba186b6203be88eb0ec30a4e2f99e51062e
DIST ujson-5.0.0.tar.gz 7128113 BLAKE2B 9ce58a57d85203f2e20690494ae627b87caf8524781eb07e63b97ecd40dbd7e25bc2e5a217fca738e4b8b2fe5bc9a9e7a7ad032a089bf8e5b5104d1e107671b7 SHA512 cda9b29baf77e5aa0f3adb8ba09445753fc6730eab95a7f483b0c0b0c8bb389d12e438324f63808e5c36815330ce6508a460700882a7661bc3640721a7cc906f
+DIST ujson-5.1.0.tar.gz 7128147 BLAKE2B edd5b944e98790f3b98c4e2dbeebd1bb058c7b10e07d7919d3354cc2bcc1c8398b5bea08d27cdad438f2aa4a5d340da377ca9ef9b4b03b3d5b0e3053787ee618 SHA512 8988696918402f9e540e878eeafb2d29ed2819d4fa6ca801251a0411981eab2663eb16599a37ffa531e2e036706bd27cb1467bac17c33579e010d106da488951
diff --git a/dev-python/ujson/ujson-5.1.0.ebuild b/dev-python/ujson/ujson-5.1.0.ebuild
new file mode 100644
index 000000000000..c96e14c48f90
--- /dev/null
+++ b/dev-python/ujson/ujson-5.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Don't manually strip files
+ sed -e '/extra_link_args/s/strip_flags/\[\]/' -i setup.py || die
+
+ distutils-r1_src_prepare
+}