summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 05:26:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 05:26:11 +0100
commit4ef8edc6f0eca627c427330815ed2847262172e5 (patch)
tree7b45824e48d678b73250ac8a58a5539e24049ab4 /dev-python/userpath
parentdev-python/scikit-build-core: Bump to 0.8.2 (diff)
downloadgentoo-4ef8edc6f0eca627c427330815ed2847262172e5.tar.gz
gentoo-4ef8edc6f0eca627c427330815ed2847262172e5.tar.bz2
gentoo-4ef8edc6f0eca627c427330815ed2847262172e5.zip
dev-python/userpath: Bump to 1.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/userpath')
-rw-r--r--dev-python/userpath/Manifest1
-rw-r--r--dev-python/userpath/userpath-1.9.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/userpath/Manifest b/dev-python/userpath/Manifest
index 70fecb8a2d14..8d2e6d919e55 100644
--- a/dev-python/userpath/Manifest
+++ b/dev-python/userpath/Manifest
@@ -1 +1,2 @@
DIST userpath-1.9.1.gh.tar.gz 11183 BLAKE2B 91d5eec83ec1720cf7f65f9d67bb09d86b6679fc540026ba0b7b99522bb4e062c35bb2d6d751684f3cbaa78bca5ab1e1cb34b25a937f744115a9b80096637858 SHA512 a98b000a0968f81131eb5a91822fda72bc38e6aa2b2a85be43974c37155cbf23aa2698dac1969f078bcca1ebcbc9bd5ef71e4437eae691b7358610bcc74859d5
+DIST userpath-1.9.2.gh.tar.gz 11191 BLAKE2B 6696e97514af104fedbb1bd8cd5cd5ecb81620d63109c63b1a157dbbad353a54909e37399bb3e2406655d171346d6863d606432502da65e3f8cc2634fe79fe92 SHA512 8016ae08eb01526cd256cd3bf12eedc3abcaad225570d08c8ca051657a84ee7c75d9a8a07bcf229896fd450bd3577b1d81442d9af7fe4c1061a82d0cdfbcfad3
diff --git a/dev-python/userpath/userpath-1.9.2.ebuild b/dev-python/userpath/userpath-1.9.2.ebuild
new file mode 100644
index 000000000000..6839e3829c3d
--- /dev/null
+++ b/dev-python/userpath/userpath-1.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform tool for adding locations to the user PATH"
+HOMEPAGE="
+ https://github.com/ofek/userpath/
+ https://pypi.org/project/userpath/
+"
+SRC_URI="
+ https://github.com/ofek/userpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest