summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/venusian
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/venusian')
-rw-r--r--dev-python/venusian/Manifest2
-rw-r--r--dev-python/venusian/metadata.xml8
-rw-r--r--dev-python/venusian/venusian-1.0.ebuild31
-rw-r--r--dev-python/venusian/venusian-1.0_alpha8.ebuild34
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/venusian/Manifest b/dev-python/venusian/Manifest
new file mode 100644
index 000000000000..dbc9dc565d2b
--- /dev/null
+++ b/dev-python/venusian/Manifest
@@ -0,0 +1,2 @@
+DIST venusian-1.0.tar.gz 45747 SHA256 1720cff2ca9c369c840c1d685a7c7a21da1afa687bfe62edd93cae4bf429ca5a SHA512 770780c4e4532b16e119365d3c9531e85aede9c2be2e3a333cfe43856271c7b232ce1b27c1379f677a7191c24e8736bf5307be7a926b613f7b81644d404e8453 WHIRLPOOL 1eedda1a8d6e15caf4af136ddd08298c7201342a841b267a489b8fb483d3d97b330e3adbe75e5bd28fcd3b62d6b6b5de57f5a520923d05195560afbfb682315d
+DIST venusian-1.0a8.tar.gz 42845 SHA256 a1b054d4ccf0859a76d900c49f419645279298d5316be3a65a1c00a40719bce0 SHA512 d10577aa8c439fed3d689538695d6e0f8db299ddcefef75e3d224b637398489e55853d124be3edffc168db485df25180fe0c4685172d64587ae07c5b80ca3f6f WHIRLPOOL a3a62d29b0a8246b4e6fe3b429a6ef6c2deb294d868dac3ce1cc3544e23e63303cced09a81aa49bc5146ebb21572e561d0c0e8e0920485bc7012f02a4b08da5a
diff --git a/dev-python/venusian/metadata.xml b/dev-python/venusian/metadata.xml
new file mode 100644
index 000000000000..c789269653bf
--- /dev/null
+++ b/dev-python/venusian/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">venusian</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/venusian/venusian-1.0.ebuild b/dev-python/venusian/venusian-1.0.ebuild
new file mode 100644
index 000000000000..c9129cf24138
--- /dev/null
+++ b/dev-python/venusian/venusian-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+#RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for deferring decorator actions"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ ~dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/venusian/venusian-1.0_alpha8.ebuild b/dev-python/venusian/venusian-1.0_alpha8.ebuild
new file mode 100644
index 000000000000..18149244c6cb
--- /dev/null
+++ b/dev-python/venusian/venusian-1.0_alpha8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_P="${PN}-1.0a8" # Sigh
+
+DESCRIPTION="A library for deferring decorator actions"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}