summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 16:36:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 16:36:34 +0200
commit002272f4effdc83eb7bdc3bd5b64f7770a83c0e3 (patch)
treee51987d224faf24edf005d1103a352492f5d3a97 /dev-python/websockets
parentapp-emacs/rpm-spec-mode: Fix byte-compilation with Emacs 28 (diff)
downloadgentoo-002272f4effdc83eb7bdc3bd5b64f7770a83c0e3.tar.gz
gentoo-002272f4effdc83eb7bdc3bd5b64f7770a83c0e3.tar.bz2
gentoo-002272f4effdc83eb7bdc3bd5b64f7770a83c0e3.zip
dev-python/websockets: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest2
-rw-r--r--dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch35
-rw-r--r--dev-python/websockets/websockets-10.0.ebuild33
-rw-r--r--dev-python/websockets/websockets-10.1.ebuild27
4 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 71abe54223dd..8b086337648b 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,3 +1 @@
-DIST websockets-10.0-src.tar.gz 276231 BLAKE2B 6170f0540bc33be3d9a71f596ffee58e6e43c2173239a8fffe4f0c2a7555f8ce26849d85ed7865a5df6a4401f01bb0c928a341598916487cc79152a5031e9bbc SHA512 532289dc411d11cffc6e5aa07013cdad9655f124fbbd5dbdfe92985caf554644976a521466b1d3cbe124de11809e395b5e83195eac87495585779591b189c4d7
-DIST websockets-10.1-src.tar.gz 299315 BLAKE2B 425e7c8597f081874127ac75003aed11ebb2cf647ce9fed9e17c955e485a7a59c95d1112524d3f0d747b796b0cc41972258661c9fc9c7972f68aaebe3223b596 SHA512 c284ec92bc133c7083a72d4f364d9ace13d3eb6d7355ae46084d8097c137cdec3933cae9d5ab72d8a517af38328cea6c39877f747f5386df54a7362271cc7e7b
DIST websockets-10.2-src.tar.gz 302766 BLAKE2B 2313bab904de3671f973191f1c43d275ede44c87811d82f22c6bd76145610ba5d4ba4d7a1b3a564bfc8c4a9b7921b2edc640af9304733e85deac1e728f0050f3 SHA512 b8c7fbe627e1c411112b0d66e561aa9bcf15d6de07a9cccd203211e0e6af49762774e09f8c5f4523fe214731ae7a96ed4b63639c7ed66fee062cdda3e5fba350
diff --git a/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch b/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch
deleted file mode 100644
index bbfb500b9094..000000000000
--- a/dev-python/websockets/files/websockets-10.0-py3.9-fix-deprecation.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/tests/legacy/test_client_server.py
-+++ b/tests/legacy/test_client_server.py
-@@ -229,7 +229,6 @@ class ClientServerTestsMixin:
- and "remove loop argument" not in expected_warnings
- ): # pragma: no cover
- expected_warnings += ["There is no current event loop"]
-- self.assertDeprecationWarnings(recorded_warnings, expected_warnings)
-
- def start_client(
- self, resource_name="/", user_info=None, deprecation_warnings=None, **kwargs
-@@ -255,7 +254,6 @@ class ClientServerTestsMixin:
- and "remove loop argument" not in expected_warnings
- ): # pragma: no cover
- expected_warnings += ["There is no current event loop"]
-- self.assertDeprecationWarnings(recorded_warnings, expected_warnings)
-
- def stop_client(self):
- try:
-@@ -457,16 +455,12 @@ class CommonClientServerTests:
- with warnings.catch_warnings(record=True) as recorded_warnings:
- unix_server = unix_serve(default_handler, path, loop=self.loop)
- self.server = self.loop.run_until_complete(unix_server)
-- self.assertDeprecationWarnings(recorded_warnings, ["remove loop argument"])
-
- try:
- # Like self.start_client() but with unix_connect()
- with warnings.catch_warnings(record=True) as recorded_warnings:
- unix_client = unix_connect(path, loop=self.loop)
- self.client = self.loop.run_until_complete(unix_client)
-- self.assertDeprecationWarnings(
-- recorded_warnings, ["remove loop argument"]
-- )
- try:
- self.loop.run_until_complete(self.client.send("Hello!"))
- reply = self.loop.run_until_complete(self.client.recv())
diff --git a/dev-python/websockets/websockets-10.0.ebuild b/dev-python/websockets/websockets-10.0.ebuild
deleted file mode 100644
index 18adcbacd68c..000000000000
--- a/dev-python/websockets/websockets-10.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="https://websockets.readthedocs.io/"
-SRC_URI="
- https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- # Fails checks for deprecations warnings on py3.9 for the loop argument
- "${FILESDIR}/${P}-py3.9-fix-deprecation.patch"
-)
-
-src_prepare() {
- # these fail due to timeouts on slower hardware
- sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
- -e 's:test_keepalive_ping(:_&:' \
- -i tests/legacy/test_protocol.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/websockets/websockets-10.1.ebuild b/dev-python/websockets/websockets-10.1.ebuild
deleted file mode 100644
index 56fdcc373e66..000000000000
--- a/dev-python/websockets/websockets-10.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="https://websockets.readthedocs.io/"
-SRC_URI="
- https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # these fail due to timeouts on slower hardware
- sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
- -e 's:test_keepalive_ping(:_&:' \
- -i tests/legacy/test_protocol.py || die
- distutils-r1_src_prepare
-}