summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 17:05:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:33:53 +0200
commitec1121aedecaaba527f3645d7d083408bbc7034d (patch)
treebea713d1216d8b33b56d12ea51e9f607ff8edbb9 /dev-python/wheel
parentdev-python/nspektr: Enable py3.11 (diff)
downloadgentoo-ec1121aedecaaba527f3645d7d083408bbc7034d.tar.gz
gentoo-ec1121aedecaaba527f3645d7d083408bbc7034d.tar.bz2
gentoo-ec1121aedecaaba527f3645d7d083408bbc7034d.zip
dev-python/wheel: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/wheel-0.37.1-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/wheel/wheel-0.37.1-r1.ebuild b/dev-python/wheel/wheel-0.37.1-r1.ebuild
index 6f72f7970f36..8b1ef52db3b6 100644
--- a/dev-python/wheel/wheel-0.37.1-r1.ebuild
+++ b/dev-python/wheel/wheel-0.37.1-r1.ebuild
@@ -5,11 +5,15 @@
EAPI=7
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
+HOMEPAGE="
+ https://github.com/pypa/wheel/
+ https://pypi.org/project/wheel/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
@@ -18,11 +22,13 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]"
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-python/setuptools[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest