summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 08:45:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 09:34:08 +0200
commit5dacc1c18bcf281eee29e0bd203cfaed629657bf (patch)
tree732d754d5a048bf626b6ac7236bb17157e4b2e34 /dev-python/wsgiproxy2
parentdev-python/tox: Bump to 3.24.2 (diff)
downloadgentoo-5dacc1c18bcf281eee29e0bd203cfaed629657bf.tar.gz
gentoo-5dacc1c18bcf281eee29e0bd203cfaed629657bf.tar.bz2
gentoo-5dacc1c18bcf281eee29e0bd203cfaed629657bf.zip
dev-python/wsgiproxy2: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest1
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index f0474ae6741d..db5ec8b30340 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1 +1,2 @@
DIST WSGIProxy2-0.4.6.tar.gz 16481 BLAKE2B c33dc34d430da795e8144e06e1d6f100cce7d0155295c2d3038567a048647a4f008dbc0156fd4234ce069b3f4ec01af0e42b174dd68c92c9cb3ff4e13be83f8a SHA512 c60d794c0c8b383bf1857ec325d6d0b4fce9c4aec4a06cbf9d7549b609633e491e137342b7bbaf4eec12462eabba63096328c8517b0685e241d1baecd5827cad
+DIST WSGIProxy2-0.5.0.tar.gz 16464 BLAKE2B be8f818a1eb3280598427d52b4a7661f5c3cb86a4701e6c3c6b9c57bfde740a0ed616f9f6df8d7f4539c6716898bb5f7ebbf245d72452d84da9862df7cbec761 SHA512 8351225ffe78069f35e636efbd508d3ccd1a3365ac8846bc8fd5712c04869d21c1f9e9e9207d286649713cb9dcbc4770cf41f2c5f06a8d72e86f290211f05c0a
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.5.0.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.5.0.ebuild
new file mode 100644
index 000000000000..5deefff8482f
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest