summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-10-21 16:07:30 -0500
committerMichał Górny <mgorny@gentoo.org>2018-10-24 14:58:02 +0200
commit7b61b7b592e772c7ffd486bd5956daec4eb810d3 (patch)
tree806292bd96f11dae5f0ba699333bc5c205d420ec /dev-python/wsproto
parentwww-client/midori: Fix net-libs/webkit-gtk dep to [opengl] (diff)
downloadgentoo-7b61b7b592e772c7ffd486bd5956daec4eb810d3.tar.gz
gentoo-7b61b7b592e772c7ffd486bd5956daec4eb810d3.tar.bz2
gentoo-7b61b7b592e772c7ffd486bd5956daec4eb810d3.zip
dev-python/wsproto: Version bump to 0.12.0
Updating to the latest available version. Closes: https://bugs.gentoo.org/669238 Signed-off-by: Oleksandr Trotsenko <oleksandr.trotsenko@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10193 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest1
-rw-r--r--dev-python/wsproto/wsproto-0.12.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index a87f546b3587..8c8a044f677f 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1 +1,2 @@
DIST wsproto-0.11.0.tar.gz 41179 BLAKE2B 72486adde659e96910bcc56efe5f3ddd71d962e2844e332eabea2a0cbe5574678be85d330fdd54f951f679dfe5b1c185641a30169cc6cd9ac6c4ed066c6a3533 SHA512 583e030dc88971b3733e5e84e5fbaa70d6043d01485cabbbf45470baa31e4f511aea55e108132fc298aeae0031542af7bdd22b7ae25b11832179025a2fde4bdd
+DIST wsproto-0.12.0.tar.gz 45252 BLAKE2B 1be690faba6665b11e2e1c1725935addb132d7008f0ae81e7d5c383a152a5d79389287b3c152cb380e0bdfc97a3438e2a48b62f3c8acf6b501427bc617225ec0 SHA512 159b7f67eff60c2514cfca17036d95017109fe251def6cec132998ac82a037484e3e248d4335539fd03491f56c491a7cf51582aa3f74a44d7d150220a875b18d
diff --git a/dev-python/wsproto/wsproto-0.12.0.ebuild b/dev-python/wsproto/wsproto-0.12.0.ebuild
new file mode 100644
index 000000000000..98cb9d8b563b
--- /dev/null
+++ b/dev-python/wsproto/wsproto-0.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ =dev-python/h11-0.8*[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Testing failed"
+}