summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-27 05:54:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-27 06:17:51 +0200
commit4848a5b312c7bfc7d1cfd06a0d9ce665342079f8 (patch)
treeacc336485d032f0f227903965c88ecdd6d51d1c5 /dev-python/zipp
parentdev-python/django-debug-toolbar: Bump to 4.4.1 (diff)
downloadgentoo-4848a5b312c7bfc7d1cfd06a0d9ce665342079f8.tar.gz
gentoo-4848a5b312c7bfc7d1cfd06a0d9ce665342079f8.tar.bz2
gentoo-4848a5b312c7bfc7d1cfd06a0d9ce665342079f8.zip
dev-python/zipp: Bump to 3.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.19.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 3dd682040384..8e81c279bc87 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
DIST zipp-3.18.1.tar.gz 21220 BLAKE2B cd2afca05cb35b79bfe2b65396cccae3de15b3aaa2566643f1ce989a2747971a54fbf3baab3d273add51c51774b444c773ced951010a24a60e088103cd808d23 SHA512 27f2a5a098c773ea878b751e5c1d4e6bb89a367cd676f0b4508f3c372e78e1522de6eb46a17c8ac22a09cc6b041e393db40d14d918c7abe44cc2158f886a8045
DIST zipp-3.18.2.tar.gz 21783 BLAKE2B 488c7ebe2a37d5d38f8aac86a578144aaa77d9acb375cb2aa45eb16e5f5d2db30be00827f580ee35b5aa85559001e457054cca1dd34dec7005c0169bd4a4f1b3 SHA512 c8ba020fe210a3c9b54da2f868c324b41d281dc50342f9ce68e493a695d8c8620ab19303fb81bd64cc458667113ef31a890e8e71180a0155a83ed9ead6049bcd
+DIST zipp-3.19.0.tar.gz 21912 BLAKE2B dafb465f60984d996bb7c0962d2fd9bbbac77dc6e4515e763f703857850e4558644fe0013ea706268402db38aa58e3d68efa116d03741a49c7c1fc2374f5238a SHA512 74b381ac79ac4db520f13d4af32c5dbed52ec8a5053a749ea99704097b3ae6a6ce75b3e34ca91929767935d4427a29a368f23734dcc034e12f8e29aea6dd5ddc
diff --git a/dev-python/zipp/zipp-3.19.0.ebuild b/dev-python/zipp/zipp-3.19.0.ebuild
new file mode 100644
index 000000000000..4c2c0b9b1eb8
--- /dev/null
+++ b/dev-python/zipp/zipp-3.19.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}