summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-14 08:14:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-14 08:27:41 +0200
commit848b651ab66eae871669e7389219743a9eb0ffc2 (patch)
tree1e8032c98507c687f882fcddc82db2292e9e351c /dev-python/zipp
parentdev-python/mkdocs-htmlproofer-plugin: Bump to 1.3.0 (diff)
downloadgentoo-848b651ab66eae871669e7389219743a9eb0ffc2.tar.gz
gentoo-848b651ab66eae871669e7389219743a9eb0ffc2.tar.bz2
gentoo-848b651ab66eae871669e7389219743a9eb0ffc2.zip
dev-python/zipp: Bump to 3.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.20.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index b7eba9136534..8d84ef837273 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
DIST zipp-3.20.0.tar.gz 23244 BLAKE2B cc7d336089b4659ac884658f93246045a617d223cc3db538160cef1d705e781d341f6384ab32928e7ef2c6644cf6a0656f2b6fa23077da5df0ec66d9b2337b8f SHA512 c141c4b8bdaf2ff7639cfb85ba36735da1ca33e68b9fdcb7f350e5bd677ca39def00178aa3d481c733162beed4aa70f93525800f1af0618529ff36ca7e32327e
DIST zipp-3.20.1.tar.gz 23848 BLAKE2B 53c29d156bc3be25c59057079f26e9a02b426c5d8424ef721c6cebe4927ede8f1c5aadb405c70f57635fc1ad3abe5d511b2cdab32415c47e8faf13162ac72b5d SHA512 ed89c46d39ce703e233929146ce78332bfdd40cfad204c070247882f144fd0ec370c7499ce682ede938593b18870fa1dce8d746a0457e93c38be485378d6b546
+DIST zipp-3.20.2.tar.gz 24199 BLAKE2B 4014ad897ce248a1ae29a1ca79fbc9c9c40c1bd261dbfbe86b205f3b43bc2bfa0e3edd3573e85b7940307950a5b73ac99e797897ebdb923b38cf2d6f9b75638f SHA512 a8a625d36d75df879284ac9c61760c8320da927e119b27a1b04e60500233ed698439558d56a792b3da94080e78cc57c15c2e62ec8af466aa3f79de4cf4818c77
diff --git a/dev-python/zipp/zipp-3.20.2.ebuild b/dev-python/zipp/zipp-3.20.2.ebuild
new file mode 100644
index 000000000000..985c6d5df2e4
--- /dev/null
+++ b/dev-python/zipp/zipp-3.20.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}