summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-13 07:11:47 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-13 07:51:37 +0100
commit88a61217795b25c2ece3ac3ec344b209a3310cff (patch)
tree9177adc599ef35d7251835d3e1bdfd10645a3b9e /dev-python/zipp
parentdev-lang/python: Bump to 3.13.0_alpha5 (diff)
downloadgentoo-88a61217795b25c2ece3ac3ec344b209a3310cff.tar.gz
gentoo-88a61217795b25c2ece3ac3ec344b209a3310cff.tar.bz2
gentoo-88a61217795b25c2ece3ac3ec344b209a3310cff.zip
dev-python/zipp: Bump to 3.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.18.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 6942cb4dbabf..01ad241f3ef3 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.17.0.tar.gz 20367 BLAKE2B d1b21b7692e77a019769cd0ab93c850a409bc1eea22e2e6eb0ecaf0c14b5c42a11110b272ee73afb111675f15dfab32aceae6515c05fd4e0c4749352e4be3c90 SHA512 efd100add7e8face19a6163d07b5efbef6f896d1f3ed2dbdd443ed7e523428bd779d1f05dfe806d4d2bbe10c17c21136f2a0b6f0cbe6000dd8a6abb86dede725
+DIST zipp-3.18.0.tar.gz 21258 BLAKE2B e1f2cb629117dbf8b30d9da7b2d7ec63c9f2dc15d7d0d70f7ac06c86c347fd2b825cf2f473bb66130c6cb0b4425c737e6b4f95034ef8d171f78b75e0ae28d1a3 SHA512 a347573ff33e1e1118fee13012c7df9f8aaf42606a3fcfcead3fb3e2bd7212de5c388c22bfd104b5a60b0d2515f13cb789dc64a0492496dd69b9807a23df0963
diff --git a/dev-python/zipp/zipp-3.18.0.ebuild b/dev-python/zipp/zipp-3.18.0.ebuild
new file mode 100644
index 000000000000..f1e7c1550400
--- /dev/null
+++ b/dev-python/zipp/zipp-3.18.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}