summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-11 04:11:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-11 04:39:35 +0100
commita67e3898dea742f84a10069c366ba37bd621b428 (patch)
treec7280129093f42dbb913ceda28bc6605964adcf1 /dev-python/zipp
parentdev-python/hatchling: Bump to 1.26.1 (diff)
downloadgentoo-a67e3898dea742f84a10069c366ba37bd621b428.tar.gz
gentoo-a67e3898dea742f84a10069c366ba37bd621b428.tar.bz2
gentoo-a67e3898dea742f84a10069c366ba37bd621b428.zip
dev-python/zipp: Bump to 3.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.21.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 0dd75f3568fb..30352f28b4d2 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.20.2.tar.gz 24199 BLAKE2B 4014ad897ce248a1ae29a1ca79fbc9c9c40c1bd261dbfbe86b205f3b43bc2bfa0e3edd3573e85b7940307950a5b73ac99e797897ebdb923b38cf2d6f9b75638f SHA512 a8a625d36d75df879284ac9c61760c8320da927e119b27a1b04e60500233ed698439558d56a792b3da94080e78cc57c15c2e62ec8af466aa3f79de4cf4818c77
+DIST zipp-3.21.0.tar.gz 24545 BLAKE2B 3a21098768c54efb1bcb049f25a7b04a16d5f02eacc6e2107dfbc358ec3e595478b407e78fa0d831f5a8f2dadd92287812bc1259db925859aeedc1174378ab2d SHA512 f57489283d979dbeb3234f66f5b6b298876209ba79cf0d7a2562f0ce4747a87fd1494d26a35734c6729620d1edfa3bf8f56769de2ae9576ac9cff074caa39331
diff --git a/dev-python/zipp/zipp-3.21.0.ebuild b/dev-python/zipp/zipp-3.21.0.ebuild
new file mode 100644
index 000000000000..985c6d5df2e4
--- /dev/null
+++ b/dev-python/zipp/zipp-3.21.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-test[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}