summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-10 19:59:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-10 20:25:36 +0200
commit4d9e50a725b6653deda8fb9ea459e4788bd11cfa (patch)
treec8d36c79153423c69ff2a6adcb45f856245c0a23 /dev-python/zipstream-ng
parentdev-python/mkdocs-material: Bump to 9.5.40 (diff)
downloadgentoo-4d9e50a725b6653deda8fb9ea459e4788bd11cfa.tar.gz
gentoo-4d9e50a725b6653deda8fb9ea459e4788bd11cfa.tar.bz2
gentoo-4d9e50a725b6653deda8fb9ea459e4788bd11cfa.zip
dev-python/zipstream-ng: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipstream-ng')
-rw-r--r--dev-python/zipstream-ng/Manifest1
-rw-r--r--dev-python/zipstream-ng/zipstream-ng-1.8.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/zipstream-ng/Manifest b/dev-python/zipstream-ng/Manifest
index e3b3029d4bc3..8af609a0d0e1 100644
--- a/dev-python/zipstream-ng/Manifest
+++ b/dev-python/zipstream-ng/Manifest
@@ -1 +1,2 @@
DIST zipstream-ng-1.7.1.tar.gz 35488 BLAKE2B e255f01945eb654d2cac9e90bb7e06e5b93d6098ff7d79de765c2c6e69dc29932c909ed9b5b3737b6fbd2050165596d78e4e4602e9f63c032e6bc087596638c8 SHA512 4e39aeb47222a7e790ee8d7281f6f41f54568eef92e26467ff249c3dec9987b766943290f6b1554cd0d5d5e7908e06a2b862e5555694c6a4a433c80264a22c9a
+DIST zipstream_ng-1.8.0.tar.gz 35887 BLAKE2B 554a16922a7f12d50deec50eabfcbc282eb20d7333c0a17e184a0f1cdc3cd07c7503c381550a96fd5d64e801a0f72e706ea791f08597793d8833a38d09baea37 SHA512 87f5ac8fb099f3faa142408a1d76521f1b4c90ded98fcd319ebe4b128cdfb0f34a41c8642c77f0420ea08d38d8c544f4406bbfc946459cd198c8fa5448964636
diff --git a/dev-python/zipstream-ng/zipstream-ng-1.8.0.ebuild b/dev-python/zipstream-ng/zipstream-ng-1.8.0.ebuild
new file mode 100644
index 000000000000..409495712f36
--- /dev/null
+++ b/dev-python/zipstream-ng/zipstream-ng-1.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A modern and easy to use streamable zip file generator"
+HOMEPAGE="
+ https://github.com/pR0Ps/zipstream-ng/
+ https://pypi.org/project/zipstream-ng/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest