summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-06-06 22:24:15 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-06-06 22:27:11 +0000
commit1e12387e11806cb9032018bb1a45180498071ecf (patch)
tree04d0c646f7774715f2fd95d1ead654dc99f86f20 /dev-python
parentsys-power/phc-intel: Version bump (fixes bug 580938). (diff)
downloadgentoo-1e12387e11806cb9032018bb1a45180498071ecf.tar.gz
gentoo-1e12387e11806cb9032018bb1a45180498071ecf.tar.bz2
gentoo-1e12387e11806cb9032018bb1a45180498071ecf.zip
dev-python/wcsaxes: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcsaxes/Manifest1
-rw-r--r--dev-python/wcsaxes/files/wcsaxes-0.8-disable_mpltest.patch14
-rw-r--r--dev-python/wcsaxes/wcsaxes-0.8.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/wcsaxes/Manifest b/dev-python/wcsaxes/Manifest
index ab9b726c0dcf..4465b4fc80da 100644
--- a/dev-python/wcsaxes/Manifest
+++ b/dev-python/wcsaxes/Manifest
@@ -1 +1,2 @@
DIST wcsaxes-0.6.tar.gz 617882 SHA256 ab8101ff742ebba79da3ff7bf777f24fcf8275886dbb5482f0a2eb3ab6756ee4 SHA512 6254fabc31b7c2e44dd86b0330592e01a688e36957e9d96348f7b4d305242e02e27d2363fd7ada37ad6dba292c66bbace9ea675f475388ed5545ac24cad1226c WHIRLPOOL e2f1d7b230fb7ba3982915638535258377fd450d47f3f191ba0a12aa1698050213353e315de2329e3f8ad359a76bfccdc4291e49eb6b0a4947d0f41305977100
+DIST wcsaxes-0.8.tar.gz 226456 SHA256 3ada54586add52e70ceb5aff9257ae9c38a71d1889fe335bce3d219c5a03c672 SHA512 77a08a99b4b3fd4f08633a10d4a3dfd6726bc1433aca2c2bdb505fd93c79a5ba3735523697c11084f0044a22a5bda345a946f5770185815f92b71b59c7fc0769 WHIRLPOOL 3acbba0c1c93f4d2ceeea3d4f236f7294e3eb306b7f3f8be7244aa5b7f35452cc21c072a5f054a7608238262f6cc0dde19b40f02cd9705182430fa0a6e9b0470
diff --git a/dev-python/wcsaxes/files/wcsaxes-0.8-disable_mpltest.patch b/dev-python/wcsaxes/files/wcsaxes-0.8-disable_mpltest.patch
new file mode 100644
index 000000000000..9426b3296c04
--- /dev/null
+++ b/dev-python/wcsaxes/files/wcsaxes-0.8-disable_mpltest.patch
@@ -0,0 +1,14 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Remove the tests that require pytest-mpl
+ Pytest_mpl is (still) not available in Debian.
+ https://github.com/astrofrog/pytest-mpl
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -11,7 +11,6 @@
+ minversion = 2.2
+ norecursedirs = build docs/_build
+ doctest_plus = enabled
+-addopts = --mpl
+
+ [ah_bootstrap]
+ auto_use = False
diff --git a/dev-python/wcsaxes/wcsaxes-0.8.ebuild b/dev-python/wcsaxes/wcsaxes-0.8.ebuild
new file mode 100644
index 000000000000..5c3c8ca79515
--- /dev/null
+++ b/dev-python/wcsaxes/wcsaxes-0.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Framework for plotting astronomical and geospatial data"
+HOMEPAGE="http://wcsaxes.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8-disable_mpltest.patch"
+)
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}