summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 11:41:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 11:49:25 +0200
commit287eeca17a63737597b044b3bdd27130bd33c9a4 (patch)
treefb80897948b50a70b4e2c08adab90a08963c4797 /dev-python
parentdev-python/requests-mock: Remove old (diff)
downloadgentoo-287eeca17a63737597b044b3bdd27130bd33c9a4.tar.gz
gentoo-287eeca17a63737597b044b3bdd27130bd33c9a4.tar.bz2
gentoo-287eeca17a63737597b044b3bdd27130bd33c9a4.zip
dev-python/geventhttpclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-2.0.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 65fe4e20570d..95269ee86af4 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,2 +1 @@
DIST geventhttpclient-2.0.2.tar.gz 73821 BLAKE2B 6e12c0a7eabf2d15540192e161f27e4ef5aa771ac8b60deb00c0dbfd804e5d81f729609649c88b9b8cd51125b06afaf3d31367896ada339731ba3606ef64edda SHA512 d22453bc4fef8d9ad3b98a137d74df1647c69c594a8fa4b49848e71ca472373e44c70e3ed3798d73aca9089495cff1b5f888d1b1e39b1da60ee9052935b7b0a1
-DIST geventhttpclient-2.0.tar.gz 73677 BLAKE2B b466f7153e646b3d9af0b301789aaa92df28dad505c375ec7fdcfb8d888d8942edba3f4c776ef4fc252756fb2a37bbee7d61c4a1e912c8c7d716a57fd49fee0e SHA512 1f53cf8636e6baba4cb0d8d7b233f903efec2d74413cfb2d768bff94f3a9b91ae59444981a1399b010e73120c390b52b1449424571c7ee9bdad818e5ce72ae8c
diff --git a/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild b/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild
deleted file mode 100644
index 350f1a9322de..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="
- https://github.com/geventhttpclient/geventhttpclient/
- https://pypi.org/project/geventhttpclient/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- app-arch/brotli[python,${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[events(+),${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid ModuleNotFoundError for tests we skip later
- sed -e '/^import dpkt.ssl/d' -i src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # These SNI tests require dpkt which is not in the tree
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # Skip tests which require internet access
- epytest -m "not online"
-}