summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-13 07:40:34 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-13 07:55:16 +0100
commit43e83a1eb7d09a120e636f008f836bdfc0ba57ef (patch)
tree1fb5165b298710fe1e7ee762f3935053b6021400 /dev-python
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-43e83a1eb7d09a120e636f008f836bdfc0ba57ef.tar.gz
gentoo-43e83a1eb7d09a120e636f008f836bdfc0ba57ef.tar.bz2
gentoo-43e83a1eb7d09a120e636f008f836bdfc0ba57ef.zip
dev-python/simsimd: Bump to 6.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-6.0.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 2678e9af632a..9d4225cbb311 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,2 +1,3 @@
DIST SimSIMD-5.9.11.gh.tar.gz 204255 BLAKE2B 6c67f47bf2beb41b8f6e091874c808a9be0da307d6bc7af5d6cca62435d1a4199cff7444b8b9f0ce04dbdd779641d635b8e7545512cfeb782ca81ef0f6e74e2e SHA512 eae6b0a509198de09a6d47c207554cc330ad1242b3a1d98d74d0fcb0c960052de1765e05d2bbe4bbb295224266dc393890a159b7fa933c6d7725685a5e50d1ec
DIST SimSIMD-6.0.3.gh.tar.gz 207321 BLAKE2B 4675a3af60e460f4af79b33cdff1d780f657ec7b2cda443ef906606034472c7f76e5c75e6abc0fa125b3ed5039f7686332148bb15a9864ca7f440d5f1bf29dc2 SHA512 cc12d00527792cf3e1c3d3cce955f6549eff72db1b7861275448292887c33a09c64963f5befb3de829ccbcb38f072afe105ca39599fd69dbfef0e9bb92b5411a
+DIST SimSIMD-6.0.5.gh.tar.gz 207462 BLAKE2B 743ede471c88ccc62349eb3c460761ff1d73940f9d455bffa0823529cf1d40d1d2d1f872e880eb3513949a893e80d01e4d402ff5a4749df2e48620ed599263d5 SHA512 c2f9fc10c8d8a7bb1c052eaad4645e85ce8d8d885b279d455e63b7b10b99feaf9c02b6d90e678166a7dde8d2fbc97e9a0afba61d781b301c1f8ab691a3996674
diff --git a/dev-python/simsimd/simsimd-6.0.5.ebuild b/dev-python/simsimd/simsimd-6.0.5.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-6.0.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}