summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-17 09:52:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-17 10:36:02 +0200
commit86ea5468efb885eb8bb590e02631a251cf977b95 (patch)
treed694cfa4633d622ab61ee37198b14d69d2e128d6 /dev-python
parentdev-python/plotly: Bump to 5.16.1 (diff)
downloadgentoo-86ea5468efb885eb8bb590e02631a251cf977b95.tar.gz
gentoo-86ea5468efb885eb8bb590e02631a251cf977b95.tar.bz2
gentoo-86ea5468efb885eb8bb590e02631a251cf977b95.zip
dev-python/humanize: Bump to 4.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 60ecfdfe7c65..d8f39ed2cfc0 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.7.0.tar.gz 72028 BLAKE2B 86926d24ca20168cd1f5dc37aad38a53be59ab786bd02c25ba54930854b4459949bfa988f3135c97f15cc51b2b9fcdcb32f85a668ddbb4af2b571d974523cc12 SHA512 2454c4b7dec6868a1626af560e4f87d7bfb8eac6a919c7d7c03254723ec58494f104f7fa365c64cb4cecf50cd6d498b4201f9fda6ac1f6d2980e9e54eebde738
+DIST humanize-4.8.0.tar.gz 72894 BLAKE2B 905c9499c9e57959cda3c66d98f4ddb1ddd04278ad53e1d139ca5ff65cf84d526ec7ba5766a6fffecda7e4f31ce9a6b1e59c377b7f37bad3c929ea3bcc77d44f SHA512 2372b9518c6037bbd6bda341cce7f04e6acd0f68c1fe7218e3201477ce12324f6b98efca2bc7024222bfcc222840cd5a6a04649269c86ded7bb81b30d1602cc9
diff --git a/dev-python/humanize/humanize-4.8.0.ebuild b/dev-python/humanize/humanize-4.8.0.ebuild
new file mode 100644
index 000000000000..681e01638c1b
--- /dev/null
+++ b/dev-python/humanize/humanize-4.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest