summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 16:53:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 17:23:12 +0100
commit8a5e3bea089824976ffadb362a2ec753766bc4ce (patch)
tree738e80236f2a2c3080799919918e3f0d546f64a1 /dev-python
parentdev-python/keystoneauth1: Bump to 5.1.2 (diff)
downloadgentoo-8a5e3bea089824976ffadb362a2ec753766bc4ce.tar.gz
gentoo-8a5e3bea089824976ffadb362a2ec753766bc4ce.tar.bz2
gentoo-8a5e3bea089824976ffadb362a2ec753766bc4ce.zip
dev-python/zeroconf: Bump to 0.47.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.47.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 3fca1c5ac315..2bc77d5613e5 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,2 +1,3 @@
DIST python-zeroconf-0.39.4.gh.tar.gz 137174 BLAKE2B 9e7d66bec5ebb52754c5a45fd584229db2f20f37cc43830b31c903a6267aadc3a45a3f8c35fd329586aa81f083dc823f0e6d6fad3dc2b6cc5ada17a2eb4a2208 SHA512 0e69a31dd31111f95eda0a44ee7d00484d8b909448eef4ef41bef6e170a410ecdae02e01cc944ad7534634aa26ef0c95b465c784ee67de1c2cd0ec4ab040d445
DIST python-zeroconf-0.47.1.gh.tar.gz 151191 BLAKE2B 30cbda51b533519b9affe52d73c96fb60d6eb4d882791729a021b41e48974ac14bac46c1ea9030d792587eb09104670b38f1000192aa202ec7e793a5f79b08cc SHA512 abb74fa3e05b962b6b93ff9df58f2bb3e029d74ca03aaebd38ee716b204ec8b8af665c97f7b9fbbf998767c9308ab7d900f39a92fae4224d5689ecbe229c01d5
+DIST python-zeroconf-0.47.3.gh.tar.gz 151413 BLAKE2B eff81832a029cf173c55290355207bfd17b1701f85c60be544252d00579ad835eb2b7c0a29c967ba62b1293d9efae953bc3b564c5ca134c2a898621584cdf544 SHA512 e1435490ba6890d9f0fe8efd7be64f0f9fd20a6ae723b176861865a8a795593db7cd797062f9977a5b1df4107781011d25bdf69dd4cc54dd94ef6e891c425df4
diff --git a/dev-python/zeroconf/zeroconf-0.47.3.ebuild b/dev-python/zeroconf/zeroconf-0.47.3.ebuild
new file mode 100644
index 000000000000..09501c2c741f
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.47.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/python-zeroconf/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}