summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 07:29:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:51 +0200
commit8fb51a77d2bd367c4be3db77fbbad31453215741 (patch)
tree8bba89a66337eb30bad5d7eb8b9ca8fd5574cfc5 /dev-python
parentdev-python/flufl-lock: Bump to 8.0.1 (diff)
downloadgentoo-8fb51a77d2bd367c4be3db77fbbad31453215741.tar.gz
gentoo-8fb51a77d2bd367c4be3db77fbbad31453215741.tar.bz2
gentoo-8fb51a77d2bd367c4be3db77fbbad31453215741.zip
dev-python/proto-plus: Bump to 1.22.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.22.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index a36f2b395b1a..23b742edb47a 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-1.22.2.gh.tar.gz 69899 BLAKE2B ad485b04e4187dd5e33259e314d807ad5541c2ddf4fb8e0a85deb195c7643194d34101428fb4fcb7dd692d60e4dd4c4037f821b8fb0049a6e36e002ce870e48a SHA512 bacb8f285417bf0e4d20898c9bb2563e16204b09fc6fb92aadfcd67ad12df388681658eaaacd9b945f4d0ad7e2ce9b95dfc938f5ccc0c4419805c53ed837b2d7
+DIST proto-plus-python-1.22.3.gh.tar.gz 94230 BLAKE2B 7d7def297a2f1b863c4226ed6af35b3ecc6cfac5d324ddc311b5d44189b45773c46b83bf242fa9f9847399e1f6a55d5b114a6a1d69fe170201201fa92747dac7 SHA512 8505656798426d07e27929bf43873ae3f46b1cbd1e1b81e41035382c6edb5e5de4a550e41985d93b3c161a5fc676a1db6fc14b8e74dce5d1b1b7bf3a80419ae4
diff --git a/dev-python/proto-plus/proto-plus-1.22.3.ebuild b/dev-python/proto-plus/proto-plus-1.22.3.ebuild
new file mode 100644
index 000000000000..3c91dd1f06fa
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.22.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme