summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-05-07 20:43:02 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-05-07 20:43:02 +0200
commitc1bb2547acbb09e1e94d7d35afae9bcc70057a1d (patch)
tree1840d56420910a9f569d2a168724fff55fd333e5 /dev-python
parentdev-cpp/glibmm: Version bump to 2.66.0 (diff)
downloadgentoo-c1bb2547acbb09e1e94d7d35afae9bcc70057a1d.tar.gz
gentoo-c1bb2547acbb09e1e94d7d35afae9bcc70057a1d.tar.bz2
gentoo-c1bb2547acbb09e1e94d7d35afae9bcc70057a1d.zip
dev-python/jupyter-dash: add to tree
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter-dash/Manifest1
-rw-r--r--dev-python/jupyter-dash/jupyter-dash-0.4.0.ebuild30
-rw-r--r--dev-python/jupyter-dash/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter-dash/Manifest b/dev-python/jupyter-dash/Manifest
new file mode 100644
index 000000000000..5ee181a10bb6
--- /dev/null
+++ b/dev-python/jupyter-dash/Manifest
@@ -0,0 +1 @@
+DIST jupyter-dash-0.4.0.tar.gz 42855 BLAKE2B 6ee097892e8175d72883005a4b8097e1069d3550d845dc8728991c78d437d74f571e3e1e4fddf7c8df716c0921a5910c9fbc654f0a56c0f177f14c7b2c1bd336 SHA512 16774dfe54122096cdf672408af8fb7f0246ba7db1429eeee21a9b10645990d859208e13b743119c90e5b0ae042eeb32e91e56205139d9cf792f5995e467ccf9
diff --git a/dev-python/jupyter-dash/jupyter-dash-0.4.0.ebuild b/dev-python/jupyter-dash/jupyter-dash-0.4.0.ebuild
new file mode 100644
index 000000000000..46cb6aa625a1
--- /dev/null
+++ b/dev-python/jupyter-dash/jupyter-dash-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Plotly Dash apps from within Jupyter environments"
+HOMEPAGE="https://plotly.com/dash/"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/ansi2html[${PYTHON_USEDEP}]
+ dev-python/dash[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_install () {
+ distutils-r1_src_install
+ mv "${D}"/usr/etc "${D}"/ || die
+}
diff --git a/dev-python/jupyter-dash/metadata.xml b/dev-python/jupyter-dash/metadata.xml
new file mode 100644
index 000000000000..7badce779b42
--- /dev/null
+++ b/dev-python/jupyter-dash/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+</pkgmetadata>