summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-29 18:16:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-29 20:27:52 -0400
commit0f9771d94c73440bcf3ece9670c3f7f5450609c5 (patch)
treeee5ef15550b750ecc61594aa319915c51b753f66 /dev-qt/qtspeech
parentdev-qt/qtshadertools: drop 6.6.9999 (diff)
downloadgentoo-0f9771d94c73440bcf3ece9670c3f7f5450609c5.tar.gz
gentoo-0f9771d94c73440bcf3ece9670c3f7f5450609c5.tar.bz2
gentoo-0f9771d94c73440bcf3ece9670c3f7f5450609c5.zip
dev-qt/qtspeech: drop 6.6.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/qtspeech-6.6.9999.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-qt/qtspeech/qtspeech-6.6.9999.ebuild b/dev-qt/qtspeech/qtspeech-6.6.9999.ebuild
deleted file mode 100644
index 867d3ddc19b8..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.6.9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm64 ~loong"
-fi
-
-IUSE="flite qml +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtmultimedia-${PV}:6
- flite? ( app-accessibility/flite )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}