summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-20 18:13:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-19 14:11:35 +0200
commit1e98a766aa767cc0bf11ad23433c5277c440d318 (patch)
treec757d9ad035c09e5f73eb2678910784b45c6b3fa /dev-qt/qtwayland
parentapp-emulation/ruffle: add 0_p20230919 (diff)
downloadgentoo-1e98a766aa767cc0bf11ad23433c5277c440d318.tar.gz
gentoo-1e98a766aa767cc0bf11ad23433c5277c440d318.tar.bz2
gentoo-1e98a766aa767cc0bf11ad23433c5277c440d318.zip
dev-qt/qtwayland: Bump to QT5_KDEPATCHSET_REV=3
Eskil Abrahamsen Blomfeldt (1): client: Fix infinite recursion with text-input-v2 Jungi Byun (1): Replace scale with devicePixelRatio for non-integer scaling Vlad Zahorodnii (1): Client: Fix buffer damage Additionally, dropping upstreamed patch. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.10-r5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 65de0537ac9c..dddef08d8d20 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,4 @@
DIST qtwayland-5.15.10-gentoo-kde-2.tar.xz 43076 BLAKE2B 735ac875c0957de47f90d08931eaaaf8d53b1db0012c7d0a592c78ae78da56ffc8a1ba9bbac0577a78d4c05a92a22acef51a6afc95db54bea2d1a2a9658b67c4 SHA512 e0131bb1f2a09597a85d1d8a402bcb1d529cbc44f62e9be8dd8eba9c10007ca4f83572ca48052529b2325cdd8d886abed1f96ba4e00768e4b1c2febe1eb5ef91
+DIST qtwayland-5.15.10-gentoo-kde-3.tar.xz 46984 BLAKE2B e0fa3708d1f91599d292d5c84e4285e165cfc14e6dfba420df487e33fb13fba3b19c4e722aa3c658eb6c33e775610a0d1363361a7dd7f67c1d2c275d852b9f4d SHA512 30333d9987311eeba7d970d75806a3fd3682856890b6c8bdf5048761f14c187dcaff45c9fed445a75c594772a2dd174eee39f550fcae25042bc7ab052e0743e1
DIST qtwayland-everywhere-opensource-src-5.15.10.tar.xz 568552 BLAKE2B c5cd4ed5ff78befb5bb49f9eb809562c418b2469aa0fa23728a1de46d57f42788bba3f87a54c8dda2ee0900c76b84213d1111fd86159dc5e6707f7b67ed386de SHA512 214b1fec7dfd815d148a7485f7811e623b06d172e58e4ee3167264a4e4b8f4aeec11474e574f91652a0bd3a48476a6747cad468f1e5035c49a55a96fc1400899
DIST qtwayland-everywhere-src-6.5.2.tar.xz 1059356 BLAKE2B 4708b78ff5c8e413edaa4d4400317f58dd068273a5eef7caf1500abf8afbe4e9ac405b6854691ef93265a7eeb0cfb7406024826a0b7c7ba3f8149218af67fd48 SHA512 520d109402f1d629481029a3b1eaab740e66135db4069c34651172bb2ad821b22de60e9956a96331d2f32a4522fc52c6a4ba99b474092d755760cad08c776477
diff --git a/dev-qt/qtwayland/qtwayland-5.15.10-r5.ebuild b/dev-qt/qtwayland/qtwayland-5.15.10-r5.ebuild
new file mode 100644
index 000000000000..2c0b9e5c9e3b
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.10-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=3
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}