summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:49:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:42 +0200
commit6df268086098d882a6324611dbefe5a9ed2d3bf7 (patch)
treefd5c4db949258f00d3b651baa975b2bfa7315078 /dev-ros/gazebo_plugins
parentdev-ros/gazebo_msgs: Bump to 2.9.1. (diff)
downloadgentoo-6df268086098d882a6324611dbefe5a9ed2d3bf7.tar.gz
gentoo-6df268086098d882a6324611dbefe5a9ed2d3bf7.tar.bz2
gentoo-6df268086098d882a6324611dbefe5a9ed2d3bf7.zip
dev-ros/gazebo_plugins: Bump to 2.9.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gazebo_plugins')
-rw-r--r--dev-ros/gazebo_plugins/Manifest1
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-2.9.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/gazebo_plugins/Manifest b/dev-ros/gazebo_plugins/Manifest
index d8a556d3cac9..0e595d61d240 100644
--- a/dev-ros/gazebo_plugins/Manifest
+++ b/dev-ros/gazebo_plugins/Manifest
@@ -1 +1,2 @@
DIST gazebo_ros_pkgs-2.8.7.tar.gz 1860830 BLAKE2B 2d0bf4774b1eff0bc658baf101d3450e5d94bcf8603a6e012b8a62422eb6a6b32e3c00c82f2854182ff990cf5017c23dac02d645c6a634d9fdb34403870ffd20 SHA512 3326c88dd7145a5beeaa0bd9c19f6abc2fb5483cfff1748b01c8f137c7223ffef80ff0df5cd0a2cb255006eaa44eef60cc878b362eed4a1d9a43a1a09ad24eaa
+DIST gazebo_ros_pkgs-2.9.1.tar.gz 1861740 BLAKE2B 56569e73184c767abeea0ac6add8aa19bb70e66f3a41fe9fc5278e540759de945467372c7a0130acdb665924ab803defa22e148a36a624d08c39835dc110e208 SHA512 47510f97060d5434619948899b416a8136545b79cd112051543212abe8ce34a30c1f868c633a3f3288fd6c0ea775162daf2eea15ca539a352c9bdb55ee336b20
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.9.1.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.9.1.ebuild
new file mode 100644
index 000000000000..cb8474d4c001
--- /dev/null
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-2.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/nodelet
+ dev-ros/angles
+ dev-ros/std_srvs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/urdf
+ dev-ros/tf
+ dev-ros/tf2_ros
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/driver_base[${PYTHON_USEDEP}]
+ dev-ros/pcl_conversions
+ dev-ros/image_transport
+ dev-ros/rosconsole
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/polled_camera
+ dev-ros/diagnostic_updater
+ dev-ros/camera_info_manager
+ dev-libs/libxml2
+ >=sci-electronics/gazebo-7:=
+ dev-libs/protobuf:=
+ dev-games/ogre
+ sci-libs/pcl
+ dev-libs/boost:=
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/ocv4.patch" )