summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-25 10:20:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-25 10:56:35 +0200
commit078a170f80eeeeed119756751c88a95ae1114f26 (patch)
treefef88c5ea2bb4d5bd8ed967bf15326e0096cf8d0 /dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild
parentros-meta/qt_gui_core: Bump to 0.3.2. (diff)
downloadgentoo-078a170f80eeeeed119756751c88a95ae1114f26.tar.gz
gentoo-078a170f80eeeeed119756751c88a95ae1114f26.tar.bz2
gentoo-078a170f80eeeeed119756751c88a95ae1114f26.zip
dev-ros/python_qt_binding: bump to 0.3.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild
new file mode 100644
index 000000000000..b7675d83d1e4
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"