summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-27 11:58:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-27 12:01:27 +0200
commit6f0405341f1ce0f33a085827bd26965cae25aabb (patch)
treef174b6296bae4fc13e59b1e7963541370a56cb88 /dev-ros/urdf
parentros-meta/robot_model: Bump to 1.12.10. (diff)
downloadgentoo-6f0405341f1ce0f33a085827bd26965cae25aabb.tar.gz
gentoo-6f0405341f1ce0f33a085827bd26965cae25aabb.tar.bz2
gentoo-6f0405341f1ce0f33a085827bd26965cae25aabb.zip
dev-ros/urdf: avoid forward declaration of class
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros/urdf')
-rw-r--r--dev-ros/urdf/files/forward_decl.patch17
-rw-r--r--dev-ros/urdf/urdf-1.12.10.ebuild2
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/urdf/files/forward_decl.patch b/dev-ros/urdf/files/forward_decl.patch
new file mode 100644
index 000000000000..8aef13eb92d4
--- /dev/null
+++ b/dev-ros/urdf/files/forward_decl.patch
@@ -0,0 +1,17 @@
+Index: urdf/urdfdom_compatibility.h.in
+===================================================================
+--- urdf.orig/urdfdom_compatibility.h.in
++++ urdf/urdfdom_compatibility.h.in
+@@ -85,10 +85,12 @@ URDF_TYPEDEF_CLASS_POINTER(Model);
+ #include <urdf_world/types.h>
+
+ namespace urdf {
++class ModelInterface;
+ typedef std::shared_ptr<ModelInterface> ModelInterfaceSharedPtr;
+ typedef std::shared_ptr<const ModelInterface> ModelInterfaceConstSharedPtr;
+ typedef std::weak_ptr<ModelInterface> ModelInterfaceWeakPtr;
+
++class Model;
+ typedef std::shared_ptr<Model> ModelSharedPtr;
+ typedef std::shared_ptr<const Model> ModelConstSharedPtr;
+ typedef std::weak_ptr<Model> ModelWeakPtr;
diff --git a/dev-ros/urdf/urdf-1.12.10.ebuild b/dev-ros/urdf/urdf-1.12.10.ebuild
index 7e228f156c7d..260fee45fc0f 100644
--- a/dev-ros/urdf/urdf-1.12.10.ebuild
+++ b/dev-ros/urdf/urdf-1.12.10.ebuild
@@ -27,3 +27,5 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-ros/cmake_modules
test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-cpp/gtest )"
+
+PATCHES=( "${FILESDIR}/forward_decl.patch" )